Timelog duration format when using csv file

is there a way to configure the Timelog field to recognize a different formatting when entering duration?

The time tracking solution we are using is outputting a csv file of the task durations in this format HH:MM:SS. Problem is when entering the duration in that format (i.e. 02:37:29), Shotgun’s Timelog field converts this to “2 days”.

I also tried changing the duration formatting in the csv file to 2h 37m 29s - which in the Timelog field is converted to “0.25 days” (or 2 hours) - missing the 37m 29s.

I also tried 2:37h, which also converted to 2 days.

Is there a way to configure the Timelog field to convert either of these two options correctly into days?

Thank you!

P.s. we can not switch to hours in the Site Preferences (just in case that would be an option to make this formatting work…)

1 Like

Unfortunately this currently isn’t possible however I strongly suggest you drop a feature request for our product team as I feel supporting more time data entry formats might be beneficial.

This being said, a trip through an Excel template with a formula that converts the time field or writing a small Python API (or REST API) script that takes the CSV file and creates records might be low hanging fruit for your technical team or a scripting savvy team member.

Thank you! Yes, I did slap out a python script to do just that. (dropping a feature request now)

Problem is, even though the formatting is Shotgun Timelog compatible, it’s not working when using the bulk import. The importer tells me all is well and lists the correctly converted days in the preview window.

But, after import I not getting any Timelog entries created (aka 0 days). I also had new tasks in my csv file that weren’t in the current list of tasks - and, as expected, the bulk importer created them, but all their days are also 0 days (no time log entries were created)…