Problem activating RV using Shotgun

Hi shotguners ,

i have problem activating RV player using Shotgun . I tried to leave it for 1 hour , and still in activating progress . Kindly advise . Thank you .

Hi @cha,

First I would try is to clear cookie and reload. Have you ever tried this two options under Shotgun dropdown meun?


Hi Ben ,

Thanks for your fast response . I did try your method , and this is what i get . :neutral_face:

Hi Cha,

The error says your site is currently not accessible. Could you be able to access your Shotgun site?


Hi Ben ,

Yes i can access to my Shotgun site :sweat_smile:

I will restart my workstation later to see whether it works . If the RV player is unlicensed , will i be able to scrub through video ? I dropped a video in as session, all i see is black space .


I think you can play local media by dragging and dropping it in a RV session, even though you are not licensed.

Try to drop a video again and then go to Window->Console to see if any error message.


Hi Ben ,

No error message . But video still unable to play , when i pressed the play button , it was always buffering. I tried to drag a video with sound , when i scrubbed through , there is sound , but no visual .

Weird :face_with_monocle:

Hi ,

Could it be caused by inaccessible to certain page ? If so, then i will need to inform our IT team to whitelist the page to enable accessibility to verify RV player.

Kindly advise . Thanks .

Hi @cha,

Sounds to me like this could be a firewall issue.
Can you check if your firewall is allowing the traffic?


Hi Bert ,

Let me forward this message to IT team . Because our company have strict policy , and only allow certain site to connect to Shotgrid . I have no problem accessing my Shotgrid project site on browser, but have issue activating license for RV player . May i know which site/ source is required for RV player license activation ?

Thanks !

Hi @cha

Can your try:

  • hit Cancel when the Activating RV Using Shotgun,
  • go into the Shotgun menu and select Shotgun Connection Details -> Clear All Shotgun Connection Details
  • re-authenticate in ShotGrid

Let us know it this works,


Hi @patrick-hubert-adsk ,

It is not working as well . I have cleared all shotgun connection details as you can see below .
When i tried to authenticate again , it still stuck at activating window .


Hi @cha

  • Could you please re-do these, but taking a screen shot of the window where you enter the URL of your site ? I want to see things as you have done them, prior to the Activation-screen-that-does-not-go-away (I know there are evidence of your site name elsewhere in the thread, but the important part to me is how you entered it)
  • Also, what version of RV is that ? I have not seen it mentioned, or I missed it.



Hi @patrick-hubert-adsk ,

I have recorded it (let me know if you can’t play the video) . The version of RV is RV 2021.0.3 .


Thanks for the video and the added information.

Unfortunately, at this point the only suggestion I have is to try to start RV from a command prompt, with the rv -resetPrefs argument.

But before you do, please check that you can run rv --help and see the help.

I am on a Mac, and I am not sure of the behaviour on a PC.

Have you opened a support ticket ?


Oh no, its not recognizable .
No I didn’t opened support ticket on this issue .
I did have a issue on upgrading from Shotgun Desktop to ShotGrid Desktop (last week ticket) . Up until now there is no reply. :sweat_smile: So i guess i try it here , because the respond is much faster

Ah, I see the problem.

You either need the full path of the rv.exe binary or do a cd to that folder.

Can you do a find for rv.exe and then just drag-and-drop the binary into your command-prompt ? This just copy the path to it.

And then do the rv --help


Hi @patrick-hubert-adsk ,

This is what i get .

We are making progress,

But rv was meant as an alias to the whole path + exe.

And now, same thing : drag and drop the rv.exe and add -resetPrefs

You full line should be:
"C:\Program Files\Shotgun\RV-2021.0.3\bin\rv.exe" -resetPrefs


Thank you so much @patrick-hubert-adsk for your patience :100:

Now it works !! Now when i drag and drop video in RV , i have visual !!

Thanks @Ben_xzj @BertST for your help on this thread . YEAH !