"Play in Rv" opens version which doesn't exist

Hi all,

I have a weird problem with opening rv from shotgun and I dont understand whats happening.
When I open a Version in rv from shotgun, rv always loads and additional empty version. It even loads the additional version, if it doesn’t exist in shotgun.

1 Like

Hello Anton,

It looks to me, like you don’t have a correct path.
It is either that sg_path_to_frames isn’t setup properly or that RV is configured so that it doesn’t play the sg_path_to_frames contents.

What does your Version Entity look like in ShotGrid?

Secondly when RV opens you can go to the ShotGrid Menu Tab then Session Prefs

  1. Swap Media - which Media is loaded on default
  2. Advanced/Set ShotGrid Config Style -In the Main viiew at the bottom it says what config you use
    if you just clicked into the main view the command will be cancelled so you don’t actually change anything.
    You can then have a look, or have someone else have a look, inside the *path-to-rv-folder*\plugins\Mu\shotgrid_fields_config_WHATEVER-WAS-DISPLAYED.mu File what MEDIA TYPES are configured.
    The Default is sg_path_to_frames so if you’ve never changed anything it is more likely to be that your preferred Media Type isn’t setup correctly.

Cheers, Henna

Hi Henna,
im pretty sure the sg_path_to_frames is set up correctly. I edited the Version Name field and added test at the end. Rv loads the correct version and for some reason loads a test2 as well.

Looks like there is no shotgrid_fields_config set. The only config in the plugins folder is called shotgrid_fields_config_standard

Thanks,
Anton

1 Like

Well test2 is an RV nuisance, where the shotgrid package increments the session manager ui names. So it probably loads the same version twice.

I’m not sure how relevant this is, but maybe the spaces in the ui name cause an error? Have you tired renaming the version code?

Also the rvlink protocoll could cause an error, that it sets up 2 sourceGroups.

Nope, spaces and even the colon in the version by Anton is not the problem…
image

That’s an interesting point, as I’m responsible for setting up the protocol in a custom way on windows in our facility, but f.e. our coordination who’s using a Mac with vanilla RV has the same issue :confused:

If it happens in Vanilla RV as well, it might be a subject for the RV Support Team.

Have you tried Open in Screeningroom for RV? Since Compare in Screeningroom is not available I wonder if it loads the source twice for you.