RV Screening room - local media

Hi, folks!

I’m trying to use RV to review rendered images from versions. And I do want to review the actual EXR-sequence located on local network storage, not the transcoded/compressed/lossy/uploaded MOV-File. Is there some kind of switch in RV UI, or are the version entities missing some information/linking/whatever?

So long, DD

Hi DD,

Make sure your sg_path_to_frames is filled out on your versions; it will use that path to load the local files. If you have high quality local movies, you can also use sg_path_to_movie and it should load that. You’ll see both much higher quality and much better performance.

If there are paths there but your specific machine isn’t mapped right, check this page out for setting up your RV_OS_PATHs

Ah! Thanks a lot! My versions had both - sg_path_to_frames and sg_path_to_movie so RV picked the mov file. Clearing the sg_path_to_movie field does the job!

@dietmar.kreider, an even better option is to set your preference. In the Shotgun->Session Prefs menu you can set your Swap Media preference there. If you set that to frames it should prefer that over movie.


Thanks! I will definitely check it out!

1 Like


The solution didn’t work for me. We have both paths filled in SG:
path_to_frame: points to local EXRs
path_to_movie: points to a local MOV that we generate from EXR. This is the movie we upload to SG.

(In advance I a sorry for redacted data, it is a project in production)

In this image, you can see that the path _to_frames field points to EXRs.

The Version has both path_to_frames and path_to_mov.

However, when I select the MOV file in the Media app and select Open in RV, it only plays back the MOV file instead of EXR frames. Based on the comments above, I have also changed the RV Session to load frames, but it didn’t make any difference (even after reloading RV)

If I remove the path_to_movie file, then RV plays back an MP4 which I assume is the one uploaded to SG. Even though the path_to_frames is still valid and points to EXRs.

Is there anything I can do to force RV to open EXRs even though there is a MOV file under path_to_movie?

We have realized in the example above, the file that is saved on disk has a different name than the string in path_to_frame on the published movie file. Once the file name matched, RV loaded EXRs as described above. This is resolved.