Path to Movie on Network Location

While “Path to Movie” works when loading a source high res version from the main OS path (Typically C:), I am having trouble with RV finding the local media when it is stored in a network location (ie my NAS external storage). Is there a way to fix this?

What you describe here is a pretty common workflow, but make sure the network path is in a format that RV can read.

One easy way to do that is to open it interactively in RV (any method, file>open or drag+drop) and then save the session out. Then you can dig through and find the movie path in the RVFileSource node. It might be that your network mount is different than specified in pathToMovie.

If you are in a collaborative environment and people mount their network drives differently, check out the RV_OS_PATH documentation (or RVPATHSWAP, but the former is potentially a bit more flexible).

Thanks for the quick response! Unfortunately the method you describe wont work for our purposes. Here is my process:

  1. I drag/drop my 4K render from the network drive “test_comp_001” to RV and use the RV submit tool, so the exact path is copied to Shotgrid “N:/TEST/test_comp_001”
  2. RV Submit tool makes a copy of my QT, and uses that as a path “” (this copy has the .mov extension included in the filename)
  3. Once uploaded, I add that version to a playlist, which I launch in Screening room for RV, but despite i select “Play Movie” in the Session Prefs, it only plays Shotgun’s low res version.

This issue doesn’t happen when I do this process from a local drive (whichever letter the drive is), so it leads me to think Shotgun has an issue with network drives.

Any ideas I could try? Ive already checked a few times that the path is correct.

Thank you!

Hi Eddie,

I took a look at the and it looks like they’ve changed a lot since I last was in there for the progressive source loading (man, RV devs, you sure had to change a lot of that!). There used to be an environment variable for ignoring a file check but I can’t seem to find it.

The opening the RV file session was just a debugging step to see what path RV sees internally, but its probably the N:/ path since that’s what the Shotgun submission tool uses.

Can you try opening/submitting from the UNC path rather than the N:/ mounted path to see if that works? Beyond that, I might have to just let the RV team answer.


1 Like

Hey Michael,

I tried submitting from the UNC path (192.168.x.xx), the network drive (N:) path, and as a network location (\anton_nas…) and none of them worked, meanwhile the desktop or internal storage paths all work. I am using a Synology Nas as my media server if that helps. but yeah, so far nothing seems to work. If you could let me know how to get in contact with the RV team that would be great. Thank you for all your help Michael! I really appreciate it.

Hi Eddie, they should be on here, otherwise you can create a ticket. I’m no longer an Autodesk employee so other than those two avenues, I’ve unfortunately, got nothing else for you to get to them, but they should see it here.


No worries Michael, thanks a lot for your help, you are awesome!

1 Like

Do all your N:\ paths include the & (from PERSONAL & WORK)? Can you try a path without that character in the path? Just thinking RV might not like that character in a path.