Cannot activate a disabled user

I disabled a user on the ShotGrid site but I need to let them back on but when I try to activate them again from the “People” page it does not work. Is there something else that needs to be done via now? I’ve also tried to activate from their page info.

Are you sure you have enough available license seats? It should display in the Top left op the People page.

Yep, it says I have 4 seats available.

Does ShotGrid display a (error) message (with details) when trying to activate?

Is there an event log created that has more info?

No error or alert and in the event logs I see nothing for attempting to make the change. It changes it to green though :wink:

Screen Shot 2022-01-12 at 2.29.11 PM

Derp, I should of thought to try this before I posted here. I started an incognito session, logged in and it worked.

1 Like

Hi @dschwarz

Happy that you managed to get things to work.

Just a clarification regarding your question in the original post : no, you do not need to do anything in

All user management is done by a ShotGrid admin, from the site itself.

Assigning licenses from does not grant access to any site, so it is usually pointless to do so.

But there is one exception: if the last admin was somehow disabled by error on the site, it is possible for one of the de-activated admins to log back in the site if they are assigned a license. This is to allow clients to get out of that specific situation by themselves, without the need for a support call. This only works if:

  1. the admin user existed already on the site at one point in time,
  2. they are assigned a license,
  3. no other admin user is active on the site.

One important thing to note : removing the license assignment of a user from will de-activate that user on all the site of that team. This is a quick way to boot out and ensure a given user no longer has access to ShotGrid. But this is an asymmetrical action : if you do this by mistake, the only way to undo that is by logging on every site of the team and re-enabling that user.

This is why we tell clients to only use ShotGrid for user management, and strongly suggest to use a separate team for the ShotGrid entitlements. Less chances of bad manipulations/errors.


1 Like


I have a similar issue trying to activate a user that was disabled
I have one seat available and I change from disabled to active and I get an error message saying failed to activate try again
I’m logged in as the admin user. I’ve tried retiring the user and un-retiring. I’ve tried creating him as a new user with a slightly different email and have also failed in exactly the same way. - Any help appreciated - Thanks


Hi @craig422

Do you have unused licenses available ?

What does the user seats available/total say ?


Hi @patrick-hubert-adsk


There is 1 seat available and this agrees with the Autodesk management portal

There was an issue when we originally migrated with Shotgrid reporting 1 seat less available than the Autodesk site but this corrected itself over the coming months. We have been running 4 or 5 seats below maximum since migration but we are now increasing headcount again so this issue has only just appeared after we got back to 1 below maximum again and we’ve tried to use it.


Hi @craig422

Just ensure that your have not used Groups with ShotGrid licenses on, as this will cause issue with the code computing the free seats.

But since ShotGrid’s People page show that you have 1 seat available, this is not the cause of your current issue.

The user that you are trying to activate:

  • do they have a valid email address ? Is the email address unusual ? (e.g. using a new domain?)
  • do they have a first name and last name set ? (look at these specific columns, instead of the Name column, which aggregates both first and last name)
  • is the name that of a person ? (e.g. not just numbers) Autodesk Identity is meant to be used by people, so we do expect to have an actual first name and last name.
  • is the name potentially a reserved word (like admin or administrator) or something that could be flagged by a profanity filter ?

When you attempt to activate the user (and it fails), can you then have a look at the event log entries page. We record attempt at sending out invitations. If there was an error, it will perhaps show there.

Hoping this helps,


Hi @patrick-hubert-adsk

All the user details were valid but we did have users assigned via a group and also direct to the product.

I removed all the people from the group and deleted it then tried again and bingo!

It works and the user is now active.

Thanks for your help