Unable to save file in a specific task

Hi all, we consistently get this error when trying to save in certain tasks:

TankError: Tried to resolve a path from the template <Sgtk TemplatePath nuke_shot_work: /{Sequence}/{Shot}/{Step}/{task_name}/work/{login}/{project_namy}_{Sequence}_{Shot}_{Step}_{name}_v{version}.nk> and a set of input fields '{'Shot': 'xxx', 'name': 'testPipe', 'Step': 'Comp', 'version': 1, 'task_name': 'Cleanup', 'login': 'mmoshev', 'project_namy': 'xxx'}' but the following required fields were missing from the input: ['Sequence']

The sequence was probably renamed or the shot moved onto a new sequence.

Strangely, if we move the task to another Step, it works, we are able to save to the task.

Is this a problem with FilesystemLocations? How do I remediate it?

1 Like

Finally fixed it. It was indeed caused by a Sequence getting renamed, and leaving behind a few FilesystemLocations, which were confusing toolkit. If anyone can shed more light on this, feel welcome.

The fix:

  • Delete stale FilesystemLocations in Shotgun
  • Unregister folders related to stale FilesystemLocations from Toolkit
  • Register folders again from Toolkit

Noticed synchronize_folders was also failing, and it suggested unregistering.


Thanks for sharing your self-solve details, @mmoshev!