Odd error - can't save new files in a particular task

I’ve got an odd situation I can’t seem to resolve. With one particular pipeline step, every time I try and version up a file in Maya within one of the steps I get an error saying “Unable to generate preview - this may be because nothing has ever been saved into this Work Area!”

I’m sure it’s got something to do with my template, but it’s only happening on this particular pipeline step.

here are the steps:

  • Shotgun-> File Open
  • Navigate to the shot/pipeline step/task
  • Click New File
  • Choose Shotgun -> File Save…
  • It lets me save as v001 no problem
  • I save, then move the camera and go Shotgun -> File Save…
  • Instead of versioning up to v2 (like all my other tasks), it gives the error above.

any thoughts on where to look? thanks! :slight_smile:


Hi @Shhlife,

See your 1:1 ticket as well. Let’s keep our conversation there first as we might need to see your log files. I’ll make sure to update the post here once the issue is solved or figured out in case anyone is following up.


1 Like

Hey @Shhlife,

If you could turn on debug logging and repeat the steps that cause the error, could you then send us the log files?

It’s also a big help if you can delete your logs before you replicate the issue so they are smaller and easier to debug.



hey all - turns out we were running into problems where the pipeline task was named ‘clothing-sim’ and shotgun seemed to be barfing on it because of the ‘-’ in the name. we renamed the step ‘character fx’ and that seemed to work!

At least… it works for most shots. We do have one particular shot where for some reason it’s still refusing to work correctly.

When I go to the shot using Shotgun -> File Open, then choose the pipeline step ‘character fx’ and the task, and then click “new” - it will create a new scene all as I expect. However, when I then go to save the file, it saves… and as soon as it’s done it seems to suddenly think my pipeline step is ‘clothing-sim’ - and then I run into the issue as above.

Has anyone seen a situation where a pipeline step ignores a name change?


1 Like

Hi Jason, assuming you’ve renamed any files/folders on disk to reflect the new task name, my guess is you might need to follow up your task renames with a ‘tank unregister_folders’ command to purge any reference to the incorrectly named folders that toolkit enters into a ‘filesystem location’ entity in SG. Hopefully that’ll do the trick.



@nico.vandenbosch thank you so much, that seems to have worked!

woo!! :slight_smile: