Error when trying to switch context due to an issue with path template

We’re getting this error when trying to Open File in any DCC during the context change:

TankError: Tried to resolve a path from the template <Sgtk TemplatePath shot_work_area_maya: work/{Episode}/{sg_sq_short_name}/{sg_short_name}/{Step}/maya> and a set of input fields '{'sg_sq_short_name': 's0400', 'Step': 'AN', 'Episode': 'eall'}' but the following required fields were missing from the input: ['sg_short_name'] // 

The shot entity does include the sg_short_name and when I run the folders or preview_folder command , they work and also output the correct path.

I think this maybe cause by incorrect filter in the shot.yml file but not sure. This is what I have:

type: "shotgun_entity"
name: "sg_short_name"
entity_type: "Shot"
filters: [ { "path": "sg_sequence", "relation": "is", "values": [ "$sequence" ] } ]
  • The folder creation resolves correctly
  • The shot’s sg_short_name fields does have a correct value

Thanks in advance for your input.


So after lots of debugging and googling, I stumbled upon this article that solve the issue.

The main issue I had was a 2 different keys with different names that were representing the same field on a sequence, in this case, sequence name and shot name.