Tk-blender: configuration not starting

I’m very new to Shotgrid and I’m trying to add a pipeline configuration for Blender support.
From the “pipeline configurations” panel, I click on “Add Pipeline Conifguration” and fill the form with those parameters:
Config name = tk-blender
Descriptor = sgtk:descriptor:git?path=
Plugin ids = basic.*

When it’s done, I open SG Desktop, I select my project then select the “tk-blender configuration” I created before.
Everything seems ok in the log but the engine never starts. It remains stuck on:

[ DEBUG] [PROXY] Invoking pre engine start callback ‘>’

Does anyone know what I’m missing please?

Thank you

I think you are confusing using an engine descriptor in the place of a Pipeline Configuration, and pointing it’s descriptor to what should be used for the engine itself. tk-blender itself is not a PC so this won’t work.

Have a double check on the steps in the readme here:

1 Like

Thank you, yes, I guess I’m mixing up many things.
I already followed the steps described in the page you shared and it’s working fine on a “centralized” based project, where I can modify config files.
The problem is that our project is using a “distributed” configuration, meaning I don’t have access to the configuration files where changes must be done to support this new engine.
But I’m probably missing something…

Hi Mathieu,

once you load your distributed config you can then use the “New Config Sandbox” option to copy the config into a dev folder of your choice.

You can then edit things in there, test things out, once it all works, zip it up and upload the zip as your new distributed confiig to the pipeline configuration of your choice (likely Primary)

That was exactly what I was looking for. Thanks a lot :slight_smile: