Shotgrid desktop : unable to load any project


I’m having a problem with Shotgrid desktop.

I created a Windows VM (virtualbox) for testing purposes (unrelated to this particular issue) and started to install all the required things for our studio on this vm. I ran the latest Shotgrid desktop installer.

I can start SG Desktop, but when I select a project after a while it hangs and crashes.
The last line I see in the console is :

Invoking pre engine start callback '>'

On all our workstations it works like it should (after the aforementioned line I get “Connecting to gui pipe …”) and the project loads in SG Desktop.

Here’s the tk-desktop.log :

tk-desktop.log (147.5 KB)

The log mentions BrokenPipeError: [WinError 109] The pipe has been ended as well as other error messages. I don’t understand what this means. Any clue would be welcome



Are you sure you are able to acces all the files you need?

Traceback (most recent call last):
  File "\\VSERVER01\shotgun\site\install\app_store\tk-desktop\v2.6.7\", line 97, in <module>
    result = main()
  File "\\VSERVER01\shotgun\site\install\app_store\tk-desktop\v2.6.7\", line 57, in main
  File "\\VSERVER01\shotgun\site\install\app_store\tk-desktop\v2.6.7\python\utils\", line 405, in handle_error
    proxy = _create_proxy(data)
  File "\\VSERVER01\shotgun\site\install\app_store\tk-desktop\v2.6.7\python\utils\", line 92, in _create_proxy
    data["proxy_data"]["proxy_pipe"], data["proxy_data"]["proxy_auth"]
  File "\\VSERVER01\shotgun\site\install\app_store\tk-desktop\v2.6.7\python\tk_desktop\", line 410, in __init__
    address=pipe, family=family, authkey=six.ensure_binary(authkey)
  File "C:\Program Files\Shotgun\Python3\lib\multiprocessing\", line 490, in Client
    c = PipeClient(address)
  File "C:\Program Files\Shotgun\Python3\lib\multiprocessing\", line 692, in PipeClient
    _winapi.WaitNamedPipe(address, 1000)
FileNotFoundError: [WinError 2] The system cannot find the file specified

Seems like the startup of the project/desktop is influenced by something.
Could it be you have environment variables relating to SG?
I.e. SHOTGUN_API_CACERTS that cannot be read?

I don’t have any Shotgun specific environment variables on that VM. It’s freshly installed. I first made sure the machine would properly connect to our network, checked that I could browse our various network shares (credentials) and added mapped drives. I then proceeded to install Shotgrid desktop.

Well this comes from the OS.
Are you sure your studio doesnt use a Site Config or custom bootstrap?

I’m not entirely sure to understand you when you mention Site config or custom bootstrap.

We have a ‘site’ pipeline configuration, ie a pipeline configuration that’s not linked to any project. That ‘site’ config is located on a server which is accessible to the VM. But I think this config is loaded only when no project has been selected in SG Desktop, right ? I assume once I select a project in SG Desktop the pipeline switches from that ‘site’ config to the pipeline config of that particular project (we use totally separate pipeline configs for each project).

Correct, the site config loads before anything else and if you have a project without any attached pipeline configs the site config would load as the default pipeline for that project.

If your project does have its own pipeline config then SG desktop displays each option in the dropdown when loading the project.

I misread your initial post, you are able to launch SG desktop and get to the Project Selection screen. The problem starts there.

Can you perhaps try setting the environment variable SHOTGUN_HOME and set that to a very short path, like c:\sg for example. Then quit SG Desktop and reopen.

If that works then you are running into a max path issue.

Hi Ricardo,

I don’t think I’m running on a max path issue because I can use SG Desktop properly on other machines (on our actual workstations). It is however failing on that virtual machine, but I don’t know why


1 Like

Can you enable debug logging and see if the logs give any more clues?

I had debug logging enabled when doing those tests

2023-01-12 15:51:32,531 [   DEBUG] [PROXY] Loading 'C:\Users\vfx\AppData\Roaming\Shotgun\nozon\authentication.yml'
2023-01-12 15:51:32,531 [   DEBUG] [PROXY] Current user is 'donat'
2023-01-12 15:51:32,531 [   DEBUG] [PROXY] Loading 'C:\Users\vfx\AppData\Roaming\Shotgun\nozon\authentication.yml'
2023-01-12 15:51:32,562 [   DEBUG] [PROXY] Checking if we need to update cached session data for site '' and user 'donat' in C:\Users\vfx\AppData\Roaming\Shotgun\nozon\authentication.yml...
2023-01-12 15:51:32,562 [   DEBUG] [PROXY] Loading 'C:\Users\vfx\AppData\Roaming\Shotgun\nozon\authentication.yml'
2023-01-12 15:51:32,562 [   DEBUG] [PROXY] Session data was already up to date.
2023-01-12 15:51:32,562 [   DEBUG] [PROXY] User retrieved for the project () is the same as for the bootstrap.
2023-01-12 15:51:32,562 [   DEBUG] [PROXY] Authenticated host:
2023-01-12 15:51:32,562 [   DEBUG] [PROXY] Authenticated login: donat.
2023-01-12 15:51:32,562 [   DEBUG] [PROXY] Authenticated http proxy: None.
2023-01-12 15:51:32,589 [   DEBUG] [PROXY] Executing tank_from_path('\\VSERVER01\shotgun\devdo2023')
2023-01-12 15:51:32,595 [   DEBUG] [PROXY] Creating StorageRoots instance from config: \\VSERVER01\shotgun\devdo2023\config
2023-01-12 15:51:32,595 [   DEBUG] [PROXY] Initializing storage roots object. Supplied config folder: \\VSERVER01\shotgun\devdo2023\config
2023-01-12 15:51:32,595 [   DEBUG] [PROXY] Storage roots file defined in the config: \\VSERVER01\shotgun\devdo2023\config\core\roots.yml
2023-01-12 15:51:32,595 [   DEBUG] [PROXY] Reading storage roots file form disk: \\VSERVER01\shotgun\devdo2023\config\core\roots.yml
2023-01-12 15:51:32,614 [   DEBUG] [PROXY] Read metadata: {'primary': {'default': True, 'linux_path': '/mnt/shared2/projects', 'mac_path': '/Volumes/shared2/projects', 'shotgun_storage_id': 1, 'windows_path': '\\\\server01\\shared2\\projects'}, 'secondary': {'linux_path': '/mnt/vol1/Projects', 'mac_path': '/Volumes/vol1/Projects', 'shotgun_storage_id': 2, 'windows_path': '\\\\sledge\\vol1\\Projects'}}
2023-01-12 15:51:32,630 [   DEBUG] [PROXY] Storage roots metadata: {'primary': {'default': True, 'linux_path': '/mnt/shared2/projects', 'mac_path': '/Volumes/shared2/projects', 'shotgun_storage_id': 1, 'windows_path': '\\\\server01\\shared2\\projects'}, 'secondary': {'linux_path': '/mnt/vol1/Projects', 'mac_path': '/Volumes/vol1/Projects', 'shotgun_storage_id': 2, 'windows_path': '\\\\sledge\\vol1\\Projects'}}
2023-01-12 15:51:32,630 [   DEBUG] [PROXY] Processing required storages defined by the config...
2023-01-12 15:51:32,630 [   DEBUG] [PROXY] Processing storage: primary - {'default': True, 'linux_path': '/mnt/shared2/projects', 'mac_path': '/Volumes/shared2/projects', 'shotgun_storage_id': 1, 'windows_path': '\\\\server01\\shared2\\projects'}
2023-01-12 15:51:32,630 [   DEBUG] [PROXY] Storage root primary explicitly marked as the default.
2023-01-12 15:51:32,630 [   DEBUG] [PROXY] Processing storage: secondary - {'linux_path': '/mnt/vol1/Projects', 'mac_path': '/Volumes/vol1/Projects', 'shotgun_storage_id': 2, 'windows_path': '\\\\sledge\\vol1\\Projects'}
2023-01-12 15:51:32,630 [   DEBUG] [PROXY] Created: 
2023-01-12 15:51:32,859 [   DEBUG] [PROXY] Bootstrapped into tk instance  ()
2023-01-12 15:51:32,859 [   DEBUG] [PROXY] Core API code located here: \\VSERVER01\shotgun\devdo2023\install\core\python\tank\
2023-01-12 15:51:32,859 [   DEBUG] [PROXY] Configuration has local bundle cache, skipping bundle caching.
2023-01-12 15:51:32,859 [   DEBUG] [PROXY] Begin starting up engine tk-desktop.
2023-01-12 15:51:32,859 [   DEBUG] [PROXY] Progress Report (95%): Resolving context...
2023-01-12 15:51:32,859 [   DEBUG] [PROXY] Progress Report (97%): Launching Engine...
2023-01-12 15:51:32,883 [   DEBUG] [PROXY] Attempting to start engine tk-desktop for context 
2023-01-12 15:51:32,883 [   DEBUG] [PROXY] Invoking pre engine start callback '>'

It hangs after that last line

Unfortunately I’m not sure whats happening.


My VM was set to use a single CPU core. I set it to 4 and now it works… hourrah :smiley:


1 Like

Sometimes things are so easy yet it takes days to figure out… Happens to the best of us! :upside_down_face:

Glad you got it resolved!

1 Like