Shotgun Menu not showing File Open Tools

I am having an issue with a couple of our user logins. Within a dcc app like Nuke, when they open the Shotgrid menu they cannot see the File Load options so they cannot set context of a shot. If I login in as another user (me) on the same machine, the options come in correctly. I have changed the user to admin permissions to check if this was an issue but have the same result.
Has anyone come across the same thing? I am stumped on how to fix this. I tried removing all of the %APPDAT% cache and rebooted as well as re-installed shotgun desktop.
Any help will be appreciated.

Anything in the SG Desktop logs, engine logs or plainly just in the DCC’s script editor?

noting is in the logs that I see. What I “dont” see is any data showing the load process of the plugins. I also see that our custom menus are not loading which I added to the which tells me that for some reason, SG desktop apps are not being picked up. But with no errors, I am not sure why that would be the case

Make sure you are not overriding any environment variables, for example NUKE_PATH or PYTHONPATH.

Only append to these variables (use sgtk.util.append_to_env_var function).
If you remove or override any needed environment then the DCC won’t load the SG integrations.

I actually found the issue. It is a set up error that I overlooked. I had specific users linked to a pipeline config but a few users that were assigned to the project, but NOT the config. So SG was defaulting back to basic state without any of the tools available. But does not give an error. Just moves right along.