Shotgrid Desktop update broken sign-in to migrated sites


We’ve completed the migration of one of our Shotgrid site since 2 weeks for the new system and everything worked fine. But we’re experiencing an issue since the latest Shotgrid Desktop app update that was pushed this morning.

Before, the Desktop app pop up to sign in was the web one to sign in with the Autodesk account (seems correct since we migrated the site), everything worked fine.
But since this morning the default sign-in window for our migrated site is the old one (Shotgrid login/password).
Therefore the log-in fails and ask the user to setup its personal access token.
If we setup the token for the artist, we’re able to log-in but it looks that it’s not the expected behavior, we should log in through the Autodesk web ui.

We’re running CentOs7 and here are the detailed versions of our current Desktop app
Edit: Log-in seems to work fine with a Shotgrid Desktop app v1.5.5

Let me know if I missed something or if there is something we can do to force the new web based sign-in from Autodesk.


Hi @q.mirioni

I will have a look (or try to have someone take a look) tomorrow,


Same here. Version 1.6.1 worked perfectly fine yesterday, but is broken today. Same for 1.7.0. CentOS.


we are sorry about this issue. We reverted back yesterday tk-framework-desktopstartup v2.1.2 release.

Can you please ask people who has the issue to delete their local install cache folder of tk-framework-desktopstatup and restart SG Desktop? It should be fine after that.

Here is the folder path: /home/[username]/.shotgun/desktop/install/app_store/tk-framework-desktopstartup/v2.1.2/

1 Like

After cleaning deskstopstartup folder and a fresh reboot the SG Desktop seems to work as it’s used to.


1 Like

Thank you for confirming Quentin.


Works without reboot too (Centos).