RV freezes on launch

RV locks up on launch, this issue has persisted through multiple RV version. Occasionally it will launch successfully. I’ve tried launching from a command line and the results are the same.

The only warnings it throws in a command prompt is this

WARNING: missing doc directory in bundle
WARNING: missing html directory in bundle

OS version Windows 10 21H2
RV versions tested with multiple versions. (7.6, 2022.0.0, 2023.3.0)

I’ve tried all the things you try to fix it. Uninstall then reinstall, reboot… etc… Has anyone run in to this or knows of a way to fix it.

Does RV have some sort of logging which you could look at?

Things that come to mind to check:

  • Update Drivers for Chipset + GPU?
  • Any Environment variables that may interfere?

When it loads successfully i get this in the console.

INFO: loaded ShotGrid config module ‘shotgrid_fields_config_standard’ (C:/Program Files/ShotGrid/RV-2022.3.0/plugins/Mu/shotgrid_fields_config_standard.mu)
INFO: using shotgrid server ‘STUDIOWEBSITE’
INFO: BlackMagic found DeckLink Mini Monitor 4K
INFO: sgtk_rv_bootstrap Looking for tk-core here: C:/Program Files/ShotGrid/RV-2022.3.0\src\python\sgtk\baked\plugin\bundle_cache\baked\tk-config-rv\v1.4.0\install\core\python
INFO: sgtk_rv_bootstrap:Looking for tk-core here: C:/Program Files/ShotGrid/RV-2022.3.0\src\python\sgtk\baked\plugin\bundle_cache\baked\tk-config-rv\v1.4.0\install\core\python
INFO: Toolkit initialization: ready to import sgtk at 0.0093689 sec.
INFO: Toolkit initialization: sgtk import complete at 4.06234 sec.
INFO: sgtk_rv_bootstrap:Will connect using
INFO: Toolkit initialization: ToolkitManager complete at 4.40826 sec.

INFO: Toolkit initialization took 6.97299 sec.

My cpu and graphics drivers are up to date.
Does RV check any ENV variables?

if you are willing to re-set your settings you could try running from command-line with -resetPrefs

Hey Mike! Remember me from R&H?

I launched from a command prompt but it goes unresponsive when the window pops up for ShotGrid account login now.

1 Like

The exact same issue is happening on the ShotGrid Create application as well. One can launch perfectly fine while the other launched moments after is Not Responsive.

I have the same problem when adding a package. If I go into rv.ini and stop the package from loading or run ‘rv.exe -nopackages’ the 2 warnings are still visible but rv continues to load. Turn it back on and it hangs at the 2 warnings. There is no debug info for why the package is failing… best bet find the last package installed and disable it. Send request to package maker and ask them what is wrong…

1 Like

This is a bizarre fix, but i think it is related to another issue i had with a multi monitor setup and launching software where the windows is located on a monitor other than the one set as “primary”

I had the same issue with Foundry’s Katana, and the fix was disabling (and deleting) this service called Nahimic running in the background. It’s some bundled sound related service relating to video games (and whenever windows updates it re-installs this software.)


1 Like