Play Cut Entity in Screening Room for RV


Has anyone managed to figure out how to play Cut entities in Screening Room for RV?

It used to be that you could just launch RV and tell it to load the Cut Entity using SG Review, which worked a charm.

Now that SG Review has been depreciated, I can’t seem to figure out how to play a Cut Entity so thought I’d check here if anyone had worked it out yet.

I’ve tried building up an RV command to load the version of the Cut as advised by support, but this doesn’t load the Cut Entity. It allows me to then choose “Play All in Timeline” - which just appends the Cut Items to to the end of the timeline. (We don’t use the Shot Entity, Cut Order field which is probably why).

We need Screening Room to use the data from the Cut Entity to add the Cut items to the correct place in the RV timeline, not the Cut Order from Shots.

Here are the two commands I’ve tried:

rv -flags ModeManagerPreload=shotgun_review_app -eval 'shotgun_review_app.theMode().setServer(""); shotgun_review_app.theMode().launchTimeline([(string, string)] {("version_id", "230842")});'

rv -flags ModeManagerPreload=shotgun_review_app -eval 'shotgun_review_app.theMode().setServer(""); shotgun_review_app.theMode().launchTimeline([(string, string)] {("entity_type", "Cut"), ("entity_id", "1819")});'

Any help figuring this one out would be greatly appreciated!


I eventually figured out that in order to use Cuts in screening room, you have to set an environment variable.


I found this in the .mu package for the shotgun_review_app, could not find this in any documentation so maybe I’m missing the up to date docs if someone could point me in the right direction.

This gives me a little clapperboard Icon on the left-hand side of the RV toolbar.

The only problem now, is that clicking that button doesn’t actually do anything. Any ideas?


Hi Mark did you find a solution for this? I am having the same issue. I can see the little clapperboard icon when lauching Screening room on my browser but once on RV it’s not here.

Hi Simon,

I’ve not go this working yet, but I think there was a wider issue for us as we don’t get the Cuts Icon on the browser version of Screening Room either - there’s ongoing support around this.

If you’ve got it in the browser, sounds like a good start so I would just check these things:

  1. Make sure you’re on the latest version of RV. I believe Cuts in Screening Room for RV is only supported with versions RV 2021.0.1+ - available here: Shotgun Software | RV Download

  2. Try out the environment variable, on Linux do this in the shell before launching:

  3. Try launching into Screening Room for RV with the following payload, from the command line, changing the cut entity ID:
    rv rvlink://-l -play -flags ModeManagerPreload=shotgun_review_app -eval 'shotgun_review_app.theMode().setServer(“”); shotgun_review_app.theMode().launchTimeline([(string, string)] {(“entity_type”, “Cut”), (“entity_id”, “1”)});

Hope that helps and you have more luck than I!