Nuke Studio Shots Processor


I’m facing a really weird issue with SG’s exporter in Nuke Studio.

I’m trying to setup a nuke studio based ingestion pipeline so I opened Nuke Studio from the SG desktop app, setup my project, loaded the edl, connected the media, etc. Also, this sequence entity was already created on shotgun prior to the ingestion for some other purposes. As a test, I selected just one single shot’s clip and on export option selected the “Process As Shotgun Shots” option. I setup the required path template and saved it as a preset. Finally, when I ran the export, it ended up creating 2 new sequence entities and created the shot inside the new sequence instead of reusing the existing sequence. I ran the exporter again and it created another 2 sequence entities.

I’m not sure if I’m overlooking some option but I have not been able to find anything that resolves this issue. Am I missing something obvious?

Nuke Studio 12.v5
Windows 10
Latest Shotgrid Desktop version


Not sure if this will fix your issue but I generally enable the "ensure unique values per project" tickbox on Sequences Names, Shotcode’s and Episode names as technically there should not be duplicates.

Aah yes, forgot about that field option. Thank you Ricardo for your suggestion! I’ll try that out. I don’t face this issue with the cuts importer tool but maybe the logic is handled within the app and nuke studio shots processor app does not handle this by default.

1 Like