Nuke Studio integration


Anyone knows how to install the Nuke studio integration plugin, because I thought it gets installed with Shotgun desktop app, but it seems it does not because I cannot find the Shotgun shot processor inside the export options.

I am using Nuke Studio 12.0v2 on Windows OS.

Your help is much appreciated!


Are you launching NS from SG Desktop? (sry got to ask!)

1 Like

yes, and tried to launch it from inside shotgun site in my browser too, but no luck.

Actually the shot gun panel is there and the shotgun menu too is there, but the shotgun shot processor inside the export settings is missing.

Ah ok, great.
Can you post the contents of your “error” panel and “script” panel from NS. Assuming there’s anything SG related shown.
Do you have any custom processors defined prior to setting SG up?
Finally, Have you saved your NS script using the SG Save (it should be in your Project panel right-click context menu).
Finally-finally, how are you launchin the “export” dialog. Are you selecting a clip on your sequence timeline and selecting export from the context menu?

  • no errors and this is the scripts panel

Resolving project…
Resolving configuration…
Starting up Toolkit…
Updating configuration…
Checking tk-nuke-quickreview v1.0.3 (1 of 15).
Checking tk-multi-setframerange v0.4.1 (2 of 15).
Checking tk-framework-adobe v1.1.0 (3 of 15).
Checking tk-framework-shotgunutils v4.4.15 (4 of 15).
Checking tk-framework-desktopclient v0.0.9 (5 of 15).
Checking tk-multi-about v0.3.0 (6 of 15).
Checking tk-framework-qtwidgets v2.9.2 (7 of 15).
Checking tk-multi-shotgunpanel v1.7.1 (8 of 15).
Checking tk-nuke v0.12.6 (9 of 15).
Checking tk-multi-loader2 v1.20.2 (10 of 15).
Checking tk-framework-adminui v0.5.2 (11 of 15).
Checking tk-framework-widget v0.2.8 (12 of 15).
Checking tk-multi-publish2 v2.5.0 (13 of 15).
Checking tk-framework-shotgunutils v5.7.3 (14 of 15).
Checking tk-framework-desktopserver v1.3.9 (15 of 15).
Resolving context…
Launching Engine…
Engine launched.

  • No custom processors
  • there is no shotgun save in the menu
    Annotation 2020-04-04 170557

and yes I select the sequence and right click > export

You won’t see a “shot” processor from exporting a “sequence” I think.

Odd that you’re not seeing the SG Save-as.
Can you show your SG “Work Area Info” page data? Lets see what apps you have configured.
Also, please enable debug logging, restart SG Desktop, and then send the log after launching Nuke Studio again.

this is the debugging log

I am new to shotgun, I don’t know if there are some settings I need to fix before integration works.

I mean I just installed Shotgun Desktop and the shotgun account is a fresh one.

I haven’t made any custom installation or configuration.

work area info

Hi @Osama.Ali,

Are you using the Basic Integrations? I’m not seeing the workfiles2 app in your log or current apps, this is a part of the advanced configuration of toolkit as it requires knowledge of the filesystem locations.

Can you let us know if you have set up the advanced configuration? The NukeStudio exporter needs the advanced setup to run.



Hi David,

This was helpful, now I have all the options available and I can export with shotgun processor now. The project setup was the missing step.

Thank you for your help!