Link version on shots page

On the Shots page, I would like to create a field that shows the last version of a shot that has been delivered. I’ve followed some examples both from the docs and these forums, but I can’t get some of the options to work.

Ben_xzj posted this in a similar topic: Can I display the status of the latest Version for each Shot on my Shots page? - #2 by Ben_xzj

But when I go to create a field, I can’t link a version to the current shot:

Am I trying to do this in the wrong section? I’m trying to do it in Shots, should it be done somewhere else? Are we inadvertently not linking Versions to Shots when we create versions? We can navigate to Shot specific Versions in ShotGrid, so I imagine that’s not the case.

Sorry for a re-post, but I posted it in a topic marked as solved. And it’s not solved for me.

That New Field dialog looks exactly like mine, but I get Current Shot working ok. Very odd.
Possibly the Shot entity is not configured for Versions? Check Site Preferences, Entities section

I checked that, and it is indeed ticked on.

If I navigate to my Versions page, I can see the link back to the shot and the task as well:

Very odd!
Making the New Field on the Shot page, choosing the “Query” Field Type sets the default Entity to Shot.
As soon as I switch it to Version, the “Current Shot” gets filled in automatically.

If I go to the Versions page, right click the Link field, and go to configure field, it shows this, which does not have Shot checked.

I’m guessing somehow our versions aren’t linked to our shots? I created a new Single Entity that is only Versions <-> Shot, and now this is working more as expected.

Is there any way of linking the versions to the shots without me manually editing this new field for all of our versions? I’m not sure why they weren’t linked previously either.

I think you should send a support request, something on yoru site seems broken to me.

It may sound illogical given that all SG sites get the same updates but its happened on a Older SG site I was part of before, a system field introduced some years ago was missing while it was present in every other sg site I had access to.

Sometimes things break.

Make sure to accurately describe your issue so you dont have to go too much back and forth, reference this thread and mention that the exact same workflow (which comes out of the box for everyone) does not work for you.

Support ticket seems like the best path here. I thought I was just doing something wrong, but turns out it was broken in some obscure way.

Thanks for going down the rabbit hole with me

1 Like

Following up on the "sometimes things break " qupte :wink: : how can you go back to an saved version of your project . is it doable ? are there settings for it ? or a certain manual procedure ? and what does the revert site function do .?

id be very interested since i started with SG only 3 days ago and a universe opened … :slight_smile:
best , eugen

Support went in and disabled “Enable Versions on this entity” and then re-enabled it, and the link between the shot and version started working, and the checkbox is now checked in the Link field.