Error Launching UE4 From Shotgun

I’ve setup my shotgun desktop app and I’ve done all the steps required or mentioned , and now after being able to get UE4 to show in the Shotgun app, once I try to Launch Unreal I get these messages:

2020-06-06 03:22:24,246 [ ERROR] [PROXY] Error calling __commands::unreal_engine_4.24.3((), {}):
Traceback (most recent call last):
File “C:\Users\USER0\AppData\Roaming\Shotgun\bundle_cache\app_store\tk-desktop\v2.4.12\python\tk_desktop\”, line 164, in _trigger_callback
callback(*args, **kwargs)
File “C:\Users\USER0\AppData\Roaming\Shotgun\babilgames\p91c38.basic.desktop\cfg\install\core\python\tank\platform\”, line 1084, in callback_wrapper
return callback(*args, **kwargs)
File “C:\Users\USER0\AppData\Roaming\Shotgun\bundle_cache\app_store\tk-multi-launchapp\v0.10.2\python\tk_multi_launchapp\”, line 125, in launch_version
*args, **kwargs
File “C:\Users\USER0\AppData\Roaming\Shotgun\bundle_cache\app_store\tk-multi-launchapp\v0.10.2\python\tk_multi_launchapp\”, line 343, in _launch_callback
“Could not create folders on disk. Error reported: %s” % err
TankError: Could not create folders on disk. Error reported: Could not resolve row id for path! Please contact support! trying to resolve path ‘D:\UEProjects\SON\D:\UEProjects\SON’. Source data set: [{‘path_cache_row_id’: 2, ‘path’: ‘D:\UEProjects\SON’, ‘metadata’: {‘root_name’: ‘primary’, ‘type’: ‘project’}, ‘primary’: True, ‘entity’: {‘type’: ‘Project’, ‘id’: 91, ‘name’: ‘SON’}}]

Can anyone help me ?

1 Like

Hi @zipco,

Welcome to the community and thanks for posting.

That path it’s trying to resolve: D:\UEProjects\SON\. Is it possible you have renamed the tank_name field on your project entity so that it doesn’t match the ...config/core/pipeline_configuration.yml ?

If your not sure, please could you attach your config and email us at so that we can take a look?


1 Like

Thanks for your reply Ben, I’ve solved this last night…
What I did was wrong by chosing the path of the UE4’s Project on my disk which was D:\UEProjects\SON\ so instead I’ve just created a new folder for Shotgun’s settings and that solved it for me!

One question that I want to ask Ben, can I have more than one config in one project ? because when I do the Unreal config from github Shotgun can’t identify After Effects or Illustrator.

1 Like

Hi @zipco,

Yes, you could have more config for one project. In pipeline configure entity, select one configure and right click clone configure. You got a copy of your current configure.

I think your question is about to add Unreal to an existing configure. You could follow this. Then you could get all supported engine in one configure.