Custom fields/media representations via

Hi All,

I’ve been looking at how to show add additional media representations when loading a Version in RV.

If found that this is possible via shotgun_fields_config_*.mu files but I’ve found a few interesting things that seem to be bugs, so I wanted to check that I’m not doing things wrong. There doesn’t seem to be a support area for RV on the Autodesk tickets system any more (presumably since OpenRV is available) so if anyone has advice about this it’d be much appreciated.

Custom vs Standard

My understanding is that if you include a file in a location that’s been added to RV_SUPPORT_PATH then RV will attempt to read that instead of the $RVHOME/plugins/Mu/ file.

However when I do this RV reports a number of syntax errors with the file, but it seems to load and read the config fields correctly. (See Fig 1. below)

If I rename the custom file that’s in the RV_SUPPORT_PATH to the syntax errors disappear and the fields are also loaded correctly. (See Fig 2. below)

Is this a known bug with false reporting, or is there some kind of bizzare syntax difference in how the “standard” and “custom” config files are handled?

Named vs standard/custom

I did try the option to set up a named custom config file via the “Set ShotGrid Config Style” option in the ShotGrid>Session Prefs menu. However this reports:

Requested custom config style '<ConfigName>' not found
loaded ShotGrid config module 'shotgrid_fields_config_standard' ()

However this appears to load the named config file anyway, which is quite confusing.

As a futher side note it does not appear possible to reset the ShotGrid Config Style option to not use anything. Does anyone know where this setting is saved and/or how it can be reset? (I tried delete the .rv folder in my $HOME dir but that had no effect).

Thanks in advance for any help you can provide.


1 Like

For anyone that may come across this later…

I found that I had missed setting the module name within my custom .mu file itself:

At the top of the file there is a line like this:

module: shotgrid_fields_config_standard

which when renamed to:

module: shotgrid_fields_config_custom

works without the syntax errors I found above.

I didn’t check this with behaviour of using a named custom fields file, but I imagine it might account for the same issues that I found there as well.

Additionally to reset the Config Style option it does seem that <PATH_TO_RV_EXE> -restPrefs does work to do this, but that does removed all preferences so I’m still not sure how to target resetting just the Config Style option.

But hopefully this helps anyone else in the future :sweat_smile:

1 Like

Hey Tom,

this is very usefull, thanks for sharing!