Create doesn't add version if something is being cached?

Hi Shotgun!

Situation: Artist needs to upload an image for review. He drops it in Create but where the image should appear it’s black. He continues anyway, adds a note, a timelog and submits for review. This never gets to our Shotgun site. No version, no note, no image. The timelog was the only thing that worked as expected.

We try again, but this time we noticed Create was downloading media (a 300mb video someone attached in the notes). If we wait until that video is “cached” and THEN submit for review, everything works correctly.

Is this expected behaviour?


1 Like


When we enter in a task, the current media is downloaded locally for better playback performances. It’s a threshold, at some point, when the media is too big, we are streaming only. That behavior per say is expected, to answer the question.

What seems to be a problem is when you don’t mind about the current media loaded in the player to add a new version. I’ll see if it’s a limitation and what can be done and get back to you.

In the meantime, to avoid the loading, you can drag and drop the version you want to upload directly over the task card in My Tasks. It will skip the loading!

Hope this help,



Does, if you are in the black player state and wait until the download is finished, the imported image finally loads in the Player ?

1 Like

Last time we tried it didn’t show up.

BUT: I’ve been trying to recreate what happened but haven’t been successful so far (Meaning it eventually shows up if I wait long enough). :S

1 Like

On my hand, it was as you described, but at the end of the download it shows up. I’ll try other scenarios to see if there is something abnormal in other cases. I’ll try to get the information from which size of media we skip the download phase.

I acknowledge it’s problematic. I’ll come back to you as soon as I can have more answers.