Cannot clone configuration - seeking solutions

I recently setup a trial SG account for my messing around and doing some more learning well away from our production sg site. I’ve got a custom pipeline up and running and would like to clone it. According to the documentation I should be able to right click on ‘Primary’ in the Pipeline Configuration’ page and select Clone. I cannot find clone anywhere. There is a ‘Duplicate Selected’ but no Primary. I figured I must have messed something up somewhere so I checked our production sg site and it’s the same thing. Has the Clone configuration been removed and changed to something else? I am admin on both sites. I have Shotgrid Desktop running while I try this in case that matters. I can access the config directory so it’s not missing.
Should I be using the Duplicate Selected menu now instead of clone? I tried that but it doesn’t bring up the clone window I am expecting.

I have used both Windows and mac to try this. The pipeline is working properly and people are publishing without issue so I don’t know that this is a problem with code anywhere. The trial pipeline I just built is with latest toolkit and Desktop.

I have been following this Shotgrid site for managing pipeline configurations:

In the dropdown menu there is a line that states ‘Open or install ShotGrid Desktop to enable this menu’. I get this line in both windows and mac and ShotGrid Desktop is running with the correct project selected.
Our Production SG site doesn’t have this line nor is there an option to Clone anything. This is from right clicking to the right of the word ‘Primary’. Also tried the contextual menu on the checkbox to the left of ‘Primary’.

I have uninstalled ShotGrid Desktop on both mac and pc and removed all ShotGrid files on disk. After a re-install and SG Desktop load the configs I still get this issue.


I’ll add one other thing I just noticed. Whenever I go to the Pipeline Configuration page in my project the Desktop Console throws this error:

2022-01-16 12:02:06,007 [ WARNING] dropping connection to peer tcp4: with abort=True: WebSocket opening handshake timeout (peer did not finish the opening handshake in time)
2022-01-16 12:02:06,009 [CRITICAL] Unhandled Error
Traceback (most recent call last):
  File "C:\Program Files\Shotgun\Python\lib\", line 754, in run
    self.__target(*self.__args, **self.__kwargs)
  File "C:\Users\admin\AppData\Roaming\Shotgun\bundle_cache\app_store\tk-framework-desktopserver\v1.5.2\python\tk_framework_desktopserver\", line 187, in start
  File "C:\Users\admin\AppData\Roaming\Shotgun\bundle_cache\app_store\tk-framework-desktopserver\v1.5.2\resources\python\src\2.7\twisted\internet\", line 1283, in run
  File "C:\Users\admin\AppData\Roaming\Shotgun\bundle_cache\app_store\tk-framework-desktopserver\v1.5.2\resources\python\src\2.7\twisted\internet\", line 1292, in mainLoop
---  ---
  File "C:\Users\admin\AppData\Roaming\Shotgun\bundle_cache\app_store\tk-framework-desktopserver\v1.5.2\resources\python\src\2.7\twisted\internet\", line 913, in runUntilCurrent
    call.func(*call.args, **
  File "C:\Users\admin\AppData\Roaming\Shotgun\bundle_cache\app_store\tk-framework-desktopserver\v1.5.2\resources\python\src\2.7\txaio\", line 111, in _notify_bucket
    notify_one_chunk(calls, self._chunk_size, max(0.0, delay_ms))
  File "C:\Users\admin\AppData\Roaming\Shotgun\bundle_cache\app_store\tk-framework-desktopserver\v1.5.2\resources\python\src\2.7\txaio\", line 105, in notify_one_chunk
    raise RuntimeError(msg)
exceptions.RuntimeError: Error(s) processing call_later bucket:
'NoneType' object has no attribute 'shutdown'