Blank white screen when trying to "Sign in using the Web." in Shotgun desktop

Just when I thought I couldn’t get any more frustrated with this Autodesk account migration, no I seem to be unable to log in using the Shotgun Desktop - macOS 11.5.1, SG Desktop 1.7.0. I click the Sign In button, and all I get is a white screen.

Will probably have to send something to support as well since I am dead in the water.

Anyone else see this?

Seems other users are also experiencing this:

May be worth commenting there to consolidate the info.

Hi @nedwilson

Qt seems to be misbehaving, and it is a difficult thing to troubleshoot at a distance.

So far, this is the second instance of this, but I know that this will occur again.

For others reading this thread, I have provided the attached Python script to @nedwilson , for him to run on his Mac and handle the authentication in the console instead of a Qt WebConsole window.


  • the latest SG Desktop (1.7.0)
  • in ShotGrid, go to your user account settings, in the Legacy Login and Personal Access Token section
  • take note of your login (this should be your old pre-Identity login,)
  • ensure that you have a password set (this should be your old pre-Identity password)
  • Ensure that you have a valid Personal Access Token set

The script.

  • Copy it wherever makes sense to you
  • make it executable ( chmod +x ), or you will need to start it with the python interpreter provided with the desktop (e.g. /Applications/ (assumes that you are on a Mac)
  • enter your site url, legacy login and passphrase

If there are no errors, then you can start the SG Desktop, and it should connect to your site automatically.

Hoping that this can serve as a workaround for those with the issue.

-Patrick (395 Bytes)


Hey, had the same. Clean browser cache helped.

Hi @grover_gol

You mean that you cleared the folder (for a Mac) ~/Library/Caches/Shotgun/SITE-NAME/QWebEngineProfile ?

(The tk-desktop.log will indicate the folder used on your machine. Look for the string Actual WebEngineProfile storage location:)

If that is all it takes, that is definitely an easy fix ! (I’ve unfortunately never been able to reproduce it on my machines)


No actually I cleaned chrome cache. Because I think it stored some authentication token or something. Not sure how exactly, but it worked out. Before that I cleaned toolkit cache via tank command but it didn’t help.

We have that issue too across the studio on mac and windows. Restarting SG desktop helps to see the login form but doesn’t fix it permanently.

We just got this on one of three VMs we use for ingest. They are otherwise identical, but we tried both 1.7.1 and 1.7.0 and reinstalling twice, and clearing both SG caches and any web cache we could find. We were able to fake it by feeling around with the mouse until we found the fields but we could not find a way to fix it.

@dennisserras this is a bug in SG desktop, only started happening once SG switched to Autodesk ID.

V1.6.1 works. Alternatively, Patrick from SG support has a Python script that will bootstrap the authentication for you.

Some have also had luck with disabling GPU acceleration for QT:

Good luck!



Thanks, Ned! We’ll give those a try.

Good to hear from you. Hope we get to work together on a project again soon!


Hi @nedwilson

For the record, and just to set expectations, I am a developer and not part of the support team. I help here when I can, but I do so on my own time.


1 Like

Hey all,

Unfortunately v1.6.1 did NOT fix the problem on the VM, nor did disabling GPU acceleration. I fear something else is going on…

Any other suggestions?

Doing more testing as it’s showing up on more and more achines. Still haven’t sorted anything. I’ll also note that these VMs do not have GPUs.

@patrick-hubert-adsk Don’t suppose this is a change from the ADSK side?


Hi @dennisserras

Are you in an environment that uses a proxy ? Could it be related to your firewall settings ?

Have you tried using ShotGrid Create and see how it behaves ?


Hi Patrick,

No we’re not using any proxies; and the autodesk site logs in fine. We have probably 100 VMs across 20 different sites, and there have been no changes on our end. I tried changing the url to a bunch of our sites and they are all having the same problem.

One thing I found was that if I right-click and choose “view page source” it launches Chrome and the sign-in loads normally - and I can sign in (though it doesn’t affect SG Desktop at all). We know that the text is there, because we can “feel” around for the fields and put them in and authenticate. This appears to be a display issue only, as far as I can tell.

Here’s a sample machine info:

OS Name Microsoft Windows 10 Pro for Workstations
Version 10.0.19043 Build 19043
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name INGEST-03
System Manufacturer VMware, Inc.
System Model VMware7,1
System Type x64-based PC
System SKU
Processor Intel(R) Xeon(R) Gold 6248 CPU @ 2.50GHz, 2500 Mhz, 2 Core(s), 2 Logical Processor(s)
Processor Intel(R) Xeon(R) Gold 6248 CPU @ 2.50GHz, 2500 Mhz, 2 Core(s), 2 Logical Processor(s)
BIOS Version/Date VMware, Inc. VMW71.00V.17369862.B64.2012240522, 12/24/2020
SMBIOS Version 2.7
Embedded Controller Version 255.255
BaseBoard Manufacturer Intel Corporation
BaseBoard Product 440BX Desktop Reference Platform
BaseBoard Version None
Platform Role Desktop
Secure Boot State On
PCR7 Configuration Binding Not Possible
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = 10.0.19041.1151
User Name INGEST-03\Ingest
Time Zone Pacific Daylight Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 8.00 GB
Available Physical Memory 5.82 GB
Total Virtual Memory 9.87 GB
Available Virtual Memory 7.83 GB
Page File Space 1.88 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not Modern Standby, Un-allowed DMA capable bus/device(s) detected, TPM is not usable
A hypervisor has been detected. Features required for Hyper-V will not be displayed.

I also tried SG Create, and I am getting a blank screen right after opening it. I do not get the option here to right-click and view source or other similar browser capabilities.


Hi @dennisserras

Given that both Create and Desktop are behaving the same way, this is clearly Qt related… So if you have already tried disabling GPU acceleration (I know, no GPU, but this is software so…)

The the only way I see to get things working again is to set the environment variable SGTK_FORCE_STANDARD_LOGIN_DIALOG which will prompt using the old legacy login with the legacy username and passphrase, which will also require a Personal Access Token (PAT) to be set

Please let us know if this works for your users.


Hey Patrick, just to make sure I’m not being dumb, will you give me the exact environment variable key/value for Windows? I added what you put on the other thread into the Windows user env vars and it didn’t seem to affect anything.


Hi @dennisserras

Just so I understand the context : were things working before and suddenly stopped working ? (e.g. you were already using Autodesk Identity to authenticate with the desktop)

If that was the case, then it means that something in your environment changed. Were the video drivers updated recently ? Was VMWare updated recently ?


The environment variables are the same for all platforms:

  • To disable the GPU acceleration : QTWEBENGINE_CHROMIUM_FLAGS which needs to be set to --disable-gpu
  • To force the use of the legacy login and passphrase: SGTK_FORCE_STANDARD_LOGIN_DIALOG to 1 (any non-empty string actually)