Advanced Project Setup Wizard: Toolkit Setup error

I’m trying to access the pipeline configuration for our project so I can customize how it launches Maya.

I am following the process laid out here Where I use the Advanced Project Setup Wizard to create a local copy of the pipeline configuration.

when I try to run the wizard, I am seeing this
image

I don’t know what to do now. I have followed the process documented before on a test project, and was able to accomplish what I need. But now that I need to work on a real project, I am locked out by this error.

The description is short on information for the uninitiated.

It is unclear what terminal is described. Neither windows cmd nor Bash understands the command tank. There is perhaps missing information about how one needs to run this terminal window ( in what directory, environment)

It is also unclear how one can “go into shotgun and clear the Project.tank_name field”. Dose this mean log into the SG web page for your project and edit Project.tank_name using the web interface?

I don’t really want to reset everything. I just want to take control of the pipeline configuration.

1 Like

I’m having this exact same problem.

I actually ran into this issue twice doing different things on two different projects:

  • I tried to setup a pipeline configuration shared in the cloud, but ran into a permissions issue at the end of setup.
  • I tried to setup a pipeline configuration locally, but ran into a permissions issue at 0% setup progress.

Now I’m dead in the water on both projects.

Just in case there was a borked local config I uninstalled and nuked all Program Files and AppData. But that didn’t help. In the cloud I can’t yet find if there’s any cached data. The pipeline configurations page for both projects shows nothing.

They have tons of documentation how to use the tank command, but they don’t have anything on how to setup the tank command. Is “tank” a registered PIP extension or a bat file setup through a registered environment path? You’d think the installer would set that up for you. Or that with all the other existing documentation, they would have remembered to document this critical step.

I found the tank.bat for one project, but it complains:
image

And trying it in the python console also throws it’s own errors for me:

I don’t know if a similar path exists for you, but after login you may be able to change directory in a cmd to a similar path, where singularity6 is your organization/site: C:\Users\bernst\AppData\Roaming\Shotgun\singularity6\site.basic.desktop\cfg:

image

And from there in a cmd I was able to run tank commands without issue that operated on the project(s) available.

@s6.bernst

Not sure if you still have the problem. You could create primary storage here.

ShotGrid Desktop might not automatically refresh the current project’s page view after running “Advanced Project Setup”, you might need to job out and back in again to refresh it to be certain.

Yep, so to “clear the Project.tank_name field”

  1. In ShotGrid Website, click on your profile picture, then click on “Projects”
  2. Show/Add a new column called “Tank Name”
  3. Clear the contents of the cell for the “Tank Name” of that project

Then to “delete all pipeline configurations”, which should really be changed to say “delete all custom pipeline configurations”:

  1. In ShotGrid Website, go to that project’s page
  2. Then click on “Other” > “Pipeline Configurations”
    This page shows the custom pipeline configurations.
  3. Select and delete them all

Then job-out-and-back-in again on ShotGrid Desktop then try “Advanced Project Setup” again

For more details on errors, check the bottom of the log file at:

  • Mac: Home Folder > Library > Logs > Shotgun > tk-desktop.log
  • Windows: Home Folder > AppData > Roaming > Shotgun > logs > tk-desktop.log
  • Linux: Home Folder > .shotgun > logs > tk-desktop.log
1 Like

thanks everyone for the suggestions. I’ll try some out and report back.

I had primary storage created there, but it was named wasn’t matched exactly; had to change “Primary Storage” to “primary”.

Renaming that helped fix part of the process last week, but didn’t helping me figure out how to create a new project specific toolkit setup, outside of what I figured from poking around in navigating to %app_data%/Roaming/Shotgun/[orgName]/site.basic.desktop/cfg/...