Unsupported media type error

Hi, we can’t load quicktime MOV - H264 into Shotgun Create 2021.1.2 on our new linux installation with fedora 33.
Note that the same file and Sg Create version works good on our older installation with fedora 32.

Error message:
ERROR: Open of ‘xxx.mov’ failed: unsupported media type.
[ PLAYER ] Failed to set composition: kPlayerInvalidSource

Any idea what’s wrong? Are there any prerequsities - libraries that need to be installed ?

From the ShotgunCreate.log:
[error] 459274 04/07/21:15:19:43.505 Rv exception: category:kUnsupportedFormat (0807), media:/xxx.mov msg:unsupported media type.

Hi @zavinator,

I’m sorry, but since we don’t support Fedora, the support here will be pretty limited. Shotgun Create, and Shotgun RV only officially support RHEL7 like distributions.

If it worked on Fedora 32 but not on Fedora 33, I suspect that the issue is related to the system libraries available on the workstation. The situation could be that some system libraries that our libraries use cannot be found, so when we try to load our library dynamically, it fails in a (semi-)gracefully way.

You can try to run ldd on Shotgun Create’s files to see if one of the files cannot find a library not shipped with Shotgun Create.

Here’s a draft of what could be used to inspect all the Shotgun Create dependencies:

find /Path/to/Create -type f | xargs -n 1 ldd 2>/dev/null | grep -i "not found"

There are no startup errors or “not found” messages. Btw we’ve got Rv working - missing libs cause that the program doesn’ start - this can be solved.
The problem with sg create is that it is starting without any error msgs, but we can’t load any movie file.
Of course, I understand that you can’t test all linux distros…