Toolkit Episode -> Sequence -> Shot -> Task

I’m trying to lay out our shot files as Episode → Sequence → Shot → Task.

Here are the changes I have made so far…

    shot_root: episodes/{Episode}/{Sequence}/{Shot}/{Step}
    sequence_root: episodes/{Episode}/{Sequence}

Added “Episodes” to schema  - core\schema\project\episodes\episodes.yml
filters: [ { "path": "project", "relation": "is", "values": [ "$project" ] } ]

Sequence parented under episode - schema\project\episodes\episode\sequence.yml
filters: [ { "path": "episode", "relation": "is", "values": [ "$episode" ] } ]

  - caption: Shots
    entity_type: Shot
    - [project, is, "{context.project}"]
    hierarchy: [sg_sequence.Sequence.episode, sg_sequence, code]

# shot_step
  - caption: Shots
    entity_type: Shot
    hierarchy: [sg_sequence.Sequence.episode, sg_sequence, code]
  - caption: Shots
    entity_type: Shot
    hierarchy: [sg_sequence.Sequence.episode, sg_sequence, code]

The file path for where the file is being saved does not seem to be getting set correctly? How is that determined?




Hi Al

Looking at what you’ve posted there, it looks to me like you’ve configured everything correctly.

I’m wondering if perhaps this is a case of needing to unregister the folders for those entities and create them again. Have you renamed any of the entities?
Please could you privately message me your site URL so I can take a closer look?



There was a sequence before called 01 which was deleted or is no longer used. It seems to be referencing that. I’ve been messing around trying to set this up so it’s very possible that there could be some stale relationships somewhere.

How do I unregister the folders?

I found this post which I think has fixed it…


Ah great, I’m glad that solved it. I did take a look at your site, to see what paths were registered, but I must admit everything looked OK, I couldn’t see anything that explained that behavior, but I guess there must have been something there.

Let us know if you see any further issues.

will do thanks for your help.

Hi there I was hopiong to do the same thing and have an episode/sequence/shot/task project set up that just works as a distributed config. The documentations here:

seems ok and I tried this, but it did not work. Should it? I honestly find that the ‘historical’ documentation for shotgun is difficult to navigate. It seems that to have a fully episodic project that created files and folders and is a distributed config, required a lot more tinkering and texting and searching than I expected.
I wonder if the people at shotgun could set up a full functioning template project including template pipeline config that supports episode/seq/ence/shot… and is a a distributed default config that can be used? Do you think thats possible, or perhaps its even available.