Statuses not saving in Tracking Settings

Hello! I am familiarizing myself with ShotGrid and have not been able to find any online or forum solutions for a current problem I am facing. I am trying to create “Pending Review” and “Revisions” statuses from the global list, but for some reason there is a real big issue with my page saving it. I apply them to the “shots” tab in the Tracking Settings. When I select them and click “save to all unarchived projects” and “ok”, the Tracking Settings tab says “Your change has been applied”- but when I exit out by clicking “Done”, it isn’t applied at all. The changes I made even disappear if I go on a different tab within Tracking Settings (e.g; Assets or Sequence). I have manager permissions on this project and cannot find out why these changes are not going through. Any help would be greatly appreciated!

Hi @salonzo, welcome to ShotGrid! :wave:

I’m not sure why you would have issues from the Tracking Settings, but there is something else you can try.

I created a new status called “Super Approved!”. It has yet to be applied to any entities, but it exists on my site, which I can see from the Admin menu under Status List.

When I go to a Shots page on any Project and try to change the status of a Shot, I won’t see my new status. To add it Shots, I can choose Configure Field…

From here I will see the statuses from my site that have been applied to this entity. I still don’t see “Super Approved!” as an option, so I will select + Add a new status.

From here, I can add statuses from the global list. I can see “Super Approved!” on the list, so I will click the checkbox and select Next.

Just like you did, I will apply to All unarchived Projects and select OK.

I can now see the “Super Approved!” status on my status list. I will make sure it’s visible (indicated by the eye symbol), and select Update Field.

Now when I am looking at any page with the Status field for a Shot, the status of “Super Approved!” will be an option.


Some things to note:

  • The status is applied to the entity whose status field I updated, so in this case it only applies to Shots. The status is not available on Assets, Tasks, etc. unless I apply it to those entities.
  • Since I applied the Status to all unarchived Projects, the Shot entity across any one of my unarchived Projects will now display the “Super Approved!” status.
  • No need to save your page when you add or remove a status, this is separate from your page design so saving won’t make a difference where status is concerned.

I’m not too sure why you would have had problems from the Tracking Settings, but it should work the same way, only it is a faster method of adding a status to multiple entity types, rather than going page by page like we did above. Now when I go to my Tracking Settings, I can see the status I just added, and can control it’s visibility from here if I want to.

I hope this helps!


1 Like