RV compatible Linux Distro

Hello, community!
Does anyone managed to find a compatible Linux distro, where RV works.
I’ve tried Ubuntu 20.04, 18.04, Centos 8, Centos 7 (probably THE one, but it’s too old for the Intel-Nuc, I’m trying to run it, most hardware is “unknown”), Fedora 34, 32. Is there any chance to run it on a somewhat current distro?
Or is lacking a NVidia grafics card already the elimination criterion?

So long, DD

Hi @dietmar.kreider !

RV officially only supports RHEL 7 with CentOS 7 being the preferred Linux distribution. Have you tried the last version of RedHat 7? Also, have you looked at installing proprietary drivers for the devices that are marked as unknown?


I’ve tested Centos7.9 from official centos website and the Autodesk Flame version (centos7.6). Both have no drivers for the network devices used in the Nuc. Same for the graphics card (Intel UHD). So I was to lazy to try installing the drivers with an USB stick or something simmilar and kept trying another Distos.

But i’ve managed to start RV on Ubuntu 18.04, after hacking around the dependecies. This way is also not working, as there is an unsupported OpenGL (driver).
Putting the whole distro shizzle aside, on my google research i’ve stumbled upon information like “RV under linux works ONLY with a NVidia GPU”. If so - it’s a showstopper for my efforts. Is there any way to use a non-Nvidia GPU for RV on linux?

Hey, installing correct network drivers is nearly impossible. To build the drivers I need the kernel-devel, make and so on. It’s so frustrating. Everything about RV is just frustrating :frowning:

I’ve been trying to get it to work in Centos 8 for a while and just figured it out today.

It now perfectly runs on CentOS 8. Here is how I got it to work.

  • I installed RV on a CentOS 7 installation made sure it ran. (this optional really but ensure RV works in that environment in the first place)
  • I then launched RV on CentOS 8 from a terminal and one by one read the names of library files RV was erroring out on (.so. files)
  • I searched for the equivalent library (.so) file from my CentOS 7 /usr/lib64 folder and copied and renamed the lib file to RV’s {RV_INSTALL_FOLDER}/lib folder.
    I had to be creative with "libssh
    " since the lib name wasn’t a perfect match but I always renamed the lib file to what RV was expecting and in the launch error message.
  • I had to do this for about 5 to 10 *.so files and then it opened and ran perfectly in CentOS 8.

The reason why it works is because the “rv” tcsh script from the /bin folder prepends the {RV_INSTALL_FOLDER}/lib folder to the “LD_LIBRARY_PATH” environment variable. Which effectively makes RV load the library files from this folder first (it takes precedent over system libs)

I hope this helps.

1 Like