Resource Planning Setup

Hey Folks,

I’m not sure how I missed it, but it looks like the new Resource Planning tools were released back in August. Exciting to hear!

I’m trying to follow the instructions to get it working on our site but I’m running into some difficulties.

The first step on the guide “Create Departments and link Pipeline steps to them”, isn’t very explicit. Thankfully we have both Departments and Pipeline Steps already set up, and I found a “Pipeline Step” field on the Department entity, so I’m assuming that’s where the association is made. Here’s the first stumble:

I want to link our Modeling dept. to our Modeling pipeline step but as I type “Mod…” here’s what I see:

We have only two Modeling pipeline steps across two separate entities on our site, yet we’re presented with 4 options. There’s no Pipeline Step Trash page, so I can’t verify if it’s also pulling options from the Trash.

Second step is to “Configure the formula for the Workload field.” Again there’s no indication where this field lives. After some hunting around the site I found it on the Task entity. The default is “duration.” Is this a good recommended starting value? Are there other examples we should follow?

The third steps states “Set the Site Preferences for Scheduling and Resource Planning.” Set them to what, from what? Our site prefs have no mention of the resource planning app/tool/page in them to configure.

Could the documentation be updated to be more explicit about what values, and where they should be configured? We’re excited to dive in and try out this new feature once we can figure out how to get it working.


Hi @brandon.foster!

We’re happy to see you’re diving in to Resources Planning! We actually just released it this morning (though the release notes were drafted starting in August). I’d recommend using the in-app set-up tour—can you access that? When in-app, you’ll be guided directly to where configurations need to happen. I’ll look into updating our documentation as well, and will have someone from the team chime in on the Pipeline Step issue you experienced.

:heart: , Shayna

Hello @brandon.foster !

If you have your Departments already created it should be easier to perform the mapping Pipeline Step <> Department from the Pipeline Step page. We allow Pipeline Step to map to a single Department, where from the Department side you can map them to multiple Pipeline Steps so it’s less strait forward. I’ll investigate the multiple Modeling list issue vs trash.

1 Like

The Workload field on Task is set to duration initially, but you can customize it to calculate to your needs if duration doesn’t reflect what’s needed (example: let’s say you use bid instead of duration, or want to calculate based on skill level). So, for starters, Duration is more common standard to base off of.

1 Like

Also, regarding the Workload field. As @shaynad mentions and as you figured it’s a Task field.

There’s explanation and you can actually perform the configuration of that field in the in-app Setup and Help in the Workload section (/res_plan/help/workload). The Configure Field dialog can be opened from there. You can also open it from other locations like the Tasks page as you did.

Duration is a good recommended starting value. With this setup all Tasks account for 1 person / day of Workload per day. One of the most common usage though is to pull from the Task > Bid field assuming that your studio is filling this value. By using Bid, the Workload is instead distributed, per day, according to the duration (bid divided by the duration). To do this the Workload field formula must look like this {est_in_mins}.

1 Like

Hi Shayna! :heart:

The Resource Planning link did not appear in the global nav until after I had linked at least one Pipeline Step and Department together. Once that was done it appeared. So it’s a little bit chicken and the egg scenario. In order to see the app, you have to do some setup. In order to get walked through the setup, you have to first enable the app.

We’ve also gone super-granular with our Department classifications and so we have 96 of them, not all of which impact the day-to-day scheduling. I see there’s the little eye icon to hide Departments in the studio view. Is there a way for me to save that layout so it’s consistent for everyone? I don’t want to have to tell our production staff to go and toggle 70 eye icons every time they want to use the app.

1 Like

The Resource Planning link/nav brick needs a page reload to appear. There might be some caching involved though. We’ll validate this but a reload should suffice which might have been triggered by entity creations and navigations on your side.

Btw, thx a lot! This is appreciated feedback!


Unfortunately, there isn’t any possibilities to perform Resource Planning page settings persistance and sharing yet. It’s stored into the Browser local data per user though. So this process only needs to be performed once per user, but everyone needs to perform it individually.

1 Like

Thanks, @bolducati! Is this a per-session sort of setting? I.e. when a user logs out, and back in again, they’ll need to reconfigure the visibility like on other non-persistent page settings in SG?

1 Like

We explicitly persist it in Browser application specific local storage which means that it will survive a log-out/log-in, no need to reconfigure. Even an empty cache/hard reload should not reset that. It only gets reset when browser users explicitly clear cookies and site data.


@brandon.foster , we made some more clarifications in our documentation per your feedback - thank you!

:heart: , Shayna

1 Like

I keep running into trouble trying to use this feature, should I open a support ticket or would here be best in case my problem+solution helps someone else?

When I try to select individual Departments I get perpetual spinners in the Overview and Detail widgets. There’s a vague JS error Uncaught (in promise) Error at shotgun.4fbce87319174e9577bf.js:2 in the console (image below).

I’ve tried full page refreshes, logging out and back in again, switching to different departments, all with the same results.

Hello Brandon,

we’re seeing the issue on Sentry here and we’d like to debug. It seems related to the Pipeline Step <> Department mapping… perhaps related to the issue with the strange Pipeline Steps that were also showing up in the Department > Pipeline Step autocomplete.

Let me get back to you on the next steps. Sorry for the issues.


Hello @brandon.foster. Just to keep you updated, we’re working the fix as we speak.


Hello @brandon.foster, we just deployed a fix: (Thursday September 30, 2021)

Bug fixes:

  • Fixed the infinite loading issue in Resource Planning when Tasks were assigned to Groups on some Department and Project pages. [SG-24059].

Please let us know if it solved your specific issues.


Thanks, Luc! Yes the infinite loading has stopped for me. Thank you!

As a follow-up, is there any way to differentiate different the same pipeline step being done by different departments?

For example we have an Environment team, and a Character team. There are modelers on each who are assigned Tasks in the modeling Pipeline Step of an Asset. How can I differentiate between the two to see the overall modeling capacity for my Environment team vs. my Character team? We have both Environment and Character Department entities, but I can only associate 1 pipeline step with 1 department.

1 Like

Hello @brandon.foster . I felt that this question was worth a new topic so I replied here:

1 Like

We are currently using the Resource Planning App on Shot Grid. But I am having an issue because the Workload Heatmap per project is showing numbers with a lot of decimals.
Is there a way to set the number of decimals shown on the Workload Heatmap per project?
Screen Shot 2021-12-08 at 3.11.05 PM