Project Name Case cached?

During the creation of a SG Project the name was set in UPPER case: TEST
This was an error so it was then edited to lower case: test
Now I visualize it correctly in SG

The issue is that in the before_app_launch I define the context like so:


and I get TEST in upper case, instead.

In the Python Console I get the same result if defining my context from the project_path while if I use context.project['name'] command I do get the lower case name test

Am I defining the context incorrectly? Why these difference?

Adding to this … here the issue again:


Any Idea?

I’ve even tried to set the Project Name through API

shotgun.update("Project", 188, {"name": "test"})

And still the issue persists.
Is there any cached data I should “flush”?

Another strange thing is that this seems to be related only to the Primary config! :exploding_head:

Have a look at the tank_name property, which corresponds to the name used for directories, etc.

Not sure what you mean …


tank_name is a field of my project entity and I don’t see how it can affect the name field which, as you can see from the prior grabs, differs in case if I query it with the shotgun.find command or the context_from_path command