Nukestudio app doesn't load propperly in a non Advanced project setup

I’m trying to setup a SG pipeline for our company.
We mostly are dealing with projects that that will take a few weeks tops.

First I went through the advanced project setup steps and everything worked as it should.

My plan was to setup a site-config which would be loaded for every project by default. I uploaded the config zip from the advanced project setup back to shotgrid. Made a new project. But when I start NukeStudio or Hiero it seems to run the Nuke app and not the NukeStudio one.

All the shotgrid menus are the Nuke ones and the “Process a SG shot” options aren’t there.
On startup it gives this error in the script editor:
ERROR 11:39:52.087:Hiero(20784): Error! Task type tk_hiero_export.sg_shot_processor.ShotgunShotProcessor Not recognized

I did found this thread which suggests changing the arguments to --studio. I tried this with both -studio and --studio as a software entity and also tried to hard code it in C:\Program Files\Shotgun\Resources\Desktop\Python\bundle_cache\app_store\tk-nuke\v0.14.5\

Going through the advanced setup steps for the new project fixes everything. But reverting back to the site config gives the same issue again.
But so far no luck. Anyone any idea?