Maya crash on startup via Shotgrid

Hello guys,

I am using Maya 2020.4 on a user’s AVELL laptop with Shotgrid v1.7.1. Every time I try to open it using Shotgrid, it simply quit Maya without any logs on the Console.

I’ve updated the machine’s GPU Drivers. Tried it with both Win 10 and 11.
Tried reinstalling both to different versions but no success. Any ideas?

One of my clients is recently experiencing the similar issue on his new Win 11 laptop with ShotGrid desktop app (v1.7.2) even he cleared any of ShotGrid caches sitting inside user’s AppData folder and relaunched the ShotGrid app (and let it freshly download all of toolkit apps).

Maya doesn’t crash if it launches directly though.

I tried to replicate the issue with ShotGrid desktop app (v1.7.2) on my machine running Win 10 and I couldn’t.

ShotGrid support team, is there any area such as environment variables or something I need check on to detect a cause of the issue?

Thank you!

Best to aim your question here:

Or provide your tk-desktop and tk-maya log files in this thread.
(Turn on Debug mode)

1 Like

Hello Keykun,

I found a solution on this other post.

But it seems like there’s a problem with OpenSSL for these new machines with 10th, 11th and 12th generation Intel Procesors.

The solution from the post has worked with two AVELL notebooks that we recently bought here. You simply need to create a new environment variable with the info below.

OPENSSL_ia32cap = ~0x200000200000000


ah yes I have seen this documented on the Foundry’s website for Nuke too.