Launching an engine-less external application from Shotgrid Desktop

New to Shotgrid pipeline dev, trying to add a shortcut to an external application to Shotgrid Desktop – won’t have an Engine for now. These docs make it sound like that should be possible but there’s no example and it’s a bit vague.

Launching Applications that do not have an Engine Yet

You can also use the launch app to start up applications that do not have a Toolkit engine yet. In this case, folders will be created on disk for the shot, task or asset you are launching from and the application will be launched, but no code will run after application startup and no ShotGrid menu will appear inside the application. This means that you can launch applications that are not yet supported by Toolkit from within ShotGrid.

In order to do this, configure the app with paths to the application you wish to launch, but leave the engine option as an empty string.

What I’ve tried so far is adding this to the launchapp settings:

settings.tk-multi-launchapp.ugs:
  engine:
  windows_path: "@path.windows.ugs"
  menu_name: UGS
  location: "@apps.tk-multi-launchapp.location"

and then in software_paths.yml

# UGS
path.windows.ugs: C:\Program Files (x86)\UnrealGameSync\UnrealGameSyncLauncher.exe

But no dice – and the logs don’t seem to have any errors/warnings about failing to find it, so it seems like this config alone is not enough to trigger an attempt. What am I missing?

You would need to reference your new app launch setting in the tk-desktop.yml file so it adds a launcher item for it in SG Desktop.

You can also simply add the Software from the web interface → Software page.
See this video for more info:

Thanks! This was the missing element.

If anybody else is finds this thread looking for precise example:

LaunchApp settings:

settings.tk-multi-launchapp.ugs:
  engine: ""
  icon: "{config_path}/icons/ugs_main.png"
  windows_path: "@path.windows.ugs"
  menu_name: UGS
  location: "@apps.tk-multi-launchapp.location"

Software Paths settings:

path.windows.ugs: C:\Program Files (x86)\UnrealGameSync\UnrealGameSyncLauncher.exe

Desktop settings:

  apps:
    ugs: "@settings.tk-multi-launchapp.ugs"

Importantly, the engine setting in LaunchApp needs to be empty string – leaving it blank/None like in my OP won’t work.

3 Likes