Integrating Shotgun into Premiere Workaround

Hi all,

had a chat to the Shotgun team and they mentioned that some users have created their own workarounds to integrate Shotgun into Premiere.

It would be really handy to be able to transfer notes to be able to update stage tags quickly and confidently during the production process.

Any thoughts?

6 Likes

Hi @Luey_Conway

@CGSoup actually posted on our old forums that they’ve got an engine working for Premiere:

May want to check that out and see if it works for you.

—Neil

3 Likes

Thanks Neil! Very helpful

2 Likes

Is there a working link for this workaround that’s linked above?

1 Like

I think this is the one that was talked about:

1 Like

Aha! Thank you!

2 Likes

Hi, I am trying to integrate the tk-premiere as per the steps in the Wiki. I am trying from a stand-alone machine without any firewall or restrictions.
I am getting
TankDescriptorIOError: Failed to download into path C:\Users\ADMIN\AppData\Roaming\Shotgun\bundle_cache\tmp\34e72cdd556f47cc8495a423e49787df: Failed to download Toolkit App Store Framework tk-framework-lmv v0.2.2. Error: Failed to download from 'https://tank.shotgunstudio.com' after 5 retries. See error log for details.

Kindly guide on how to build the zxp and integrate with Shotgun Toolkit.
Thank you.
Make.log (9.0 KB)

Attempt 0: Attachment download of id 27822 from https://tank.shotgunstudio.com failed: out of memory
You are out of memory. Is your disk full?

1 Like

Thanks for replying. No I checked, there is 25+ Gigs of free space on hard disk , even Memory usage in Task Manager is around 50-60% Used, and I ran Command Prompt as Administrator.

Perhaps the path length is too long.
Try setting the env variable SHOTGUN_HOME to somewhere on another drive, preferably closest to the root possible.

Then start a new Sg desktop (it will be completely fresh as it will look at the new dir).
Then try your method.

On Windows theer is a 255 character path limit by default (which can be disabled via the policy editor or registry).
This has caused me issues before as well.

1 Like

Thank you so much @Ricardo_Musch , that trick worked.
build_plugin.log (30.6 KB)

I then installed the plugin using tool from aescripts site. On launching Premiere directly from Start Menu, I faced the attached error. I am unable to get the full path in error. Read couple of log files of Premiere, but no luck.

Please guide. Thank you.

1 Like

I wonder if you need to load premiere from sg desktop?
(With the engine defined as tk-premiere)

Thanks Ricardo, I tried to configure, but I am not able to get Premiere icon visible in Shotgun Desktop App UI. I did the steps mentioned tk-premiere(wiki) . Thank you for helping me reach this far.

Did you configure Premiere in the Software Entities on your site?

Yes, from that wiki page, I did these steps
5. Add Premiere Project item to Shotgun’s Published File Types page.
6. Add Adobe Premiere Pro CC to Shotgun’s Software page. Upload the Pr icon.

Is there anything more to be done on Site ? I am being a bit naïve.


This should definitely show the Premiere icon somewhere in Sg desktop.
Take a look at your tk-desktop.yml settings and potentially remove any edits you did for tk-premiere.

Also, obviously, reload the project for this to show.

Thank you, there was a typo in tk-desktop.yml. I missed the second * before "

groups:
  matches:
   - "*Premiere*"

Now, Premiere is launched from SG Desktop, however that error is still coming related to sg_constants when Premiere startup as I posted before. I felt this file is related but seems ok to me. (changed .js to .log)
constants_js.log (2.9 KB)

1 Like