How can I set it so that the Creative Brief from asset is viewable by Vendor permissions

Hi all,

So I have an asset, with a creative brief. Brief can be seen by manager and admin roles (no one has artist role to check). A vendor has a task associated to the asset, but they are unable to see the creative brief on the asset. Vendor permissions are default and in People Permissions, Vendor → Field Permissions → Asset → Creative Brief → See is checked.

Not sure what the problem is. Thanks.

“Creative Brief” is not vanilla SG, so questions:

  • Is “Creative Brief” a custom entity? If so, does Vendor have permissions to view it?
  • Does the Asset “Creative Brief” field show as empty for the Vendor? Or the Vendor can’t load the link that is the field value?

Yes, it’s a custom field.

As far as I can tell, the vendor has permission to view it.

The field shows up in the asset page, but it displays as empty for the vendor instead of showing the web link that’s in the field. (They don’t see the link at all)

If they can’t see the link, then it’s likely they don’t have permissions to view the entity.
Check Site Settings, Entities section for this entity

The field is part of the ASSET entity. As far as I can tell, vendors have permission.

In Site Preferences → Entities → Assets, Who can see Assets?
Vendor (Custom) is checked.

In Permission - People → Vendor → Field Permissions → Asset → Creative Brief,
See is checked.

I have no idea what other permission might control this. Argh.

Thanks for your help btw.

What is the field type of Creative Brief?