High DPI on Mac

Hello, I’m using RV-2024.1.0 on a Mac with a 4k Eizo monitor. The native resolution of the monitor is 4096x2160, but under the MacOS settings it is set to emulate 2048x1980 to be easier on the eyes. In this mode I cannot get RV to display 1:1 correctly as it doesn’t appear to be High DPI aware. Our in-house review tool on the same machine displays 1:1 correctly.

Is there a way to fix this? I’ve tried setting all the various QT environment variables but understandably they have no affect under MacOS. I’ve also tried editing the Info.plist in the RV.app to enable “HighResolutionCapable” also with no luck.