Bad QT_SCALE_FACTOR and High-DPI support for 4K monitors

Hi again,

Since rv is using Qt 5.15.3 (2022 versions), the High-DPI supported by QT is not correctly handled by the rv renderView.

Examples : under Linux : rv 2022.3.0 :

  • with 4K Eizo High-DPI screen device with a system that configure

: The renderView don’t fit the QT widget area correctly :

  • It’s possible to reproduice same artefacts under a classic screen device by setting a QT_SCALE_FACTOR env var != 1.0 :
    setenv QT_SCALE_FACTOR 1.8

and optionally :

: screenshot with 2 values of QT_SCALE_FACTOR : 1.5 and 0.5 :

Currently we have disable these kind of variables in an homemade rv launcher,
but the font size, icones, menus and others gui widgets are a little bit small.
So it’s not so urgent, but we hope you will find a better fix than deactivate this QT High-DPI support.


1 Like

Hey Alec,

great stuff.

The RV team does seem to follow threads on the forum but it may be good to bring this under the attention throigh a support ticket as well (just link to this forum thread).

That would make it officially logged as a bug.

Thanks @Ricardo_Musch !
I finally succeeded to validate my autodesk account.
And re post issues I saw in rv.
Hoping that it is now in the right place and that it will be taken into account.

1 Like

Hi, we are also having this issue - is the ticket submitted something we can get an update on?

1 Like