Clarisse integration with tk-clarisse


I’ve been looking into integrating Clarisse with our Shotgun pipeline. Since there’s no official Clarisse engine yet, I’ve been trying to implement the engine kindly developed by Diego Garcia Huerta:

I’ve followed all of the steps outlined in the README to edit my config and add tk-clarisse to it. However, I am still unable to see the Clarisse app in Shotgun Desktop. If I hard code the path to the Clarisse executable under the Software page on my Shotgun site though - Shotgun Desktop picks it up and I’m able to launch Clarisse with the tk-clarisse engine running without any issue.

My question would how can I ensure any custom engine and app get automatically picked up by the Shotgun Desktop app launcher? Where is that configured and how can I debug it?

Many thanks!


Hi @viktor_petrov, so newer engines usually have a that contains some logic for automatically finding the software. It looks like @Diego_Garcia_Huerta included the logic for finding the software automatically:

and it’s using these search templates:

Usually, the engine will look in the obvious/default locations for the software, and if you have it installed anywhere else, then it is expected that you need to provide the path to it.

Is your software in the default location?


Hi @philip.scadding

Thank you for the reply. Please find attached my path to the Clarisse executable compared to the executable templates defined in As far as I can tell, the path should be matching the template.

If I try to log the activity of the _find_software method, I do not see any output in the Shotgun console whenever I start up Shotgun Desktop, which makes me think the app doesn’t register properly. I’m integrating tk-clarisse via git, based on the attached image, is its location correct?

1 Like

OK, so just to confirm,

  1. You’ve added some log lines to the cached version of the engine in your config’s install folder.
  2. You’ve not set any path on the Software entity for Clarisse in shotgun.
  3. You’ve set the engine field on the Software entity to be tk-clarisse.

Obviously I can’t rule out that there isn’t a bug in this code as we don’t test it, but it seems at the moment that it is probably not the cause. Certainly I would expect your log lines to appear, so if they are not the, that might indicate the issue.

They may seem like silly questions, but are you certain you are using that config you are editing, and that your descriptor is pointing to that exact version of the engine you are adding the log lines to?

If none of this helps, please pop a support ticket in mentioning this post, and provide a copy of your log where debug was enabled. Also a copy of your config. Then we’ll dig in further and respond back here.

Where are my log files?
How do I turn on debug logging?

1 Like

Hi @philip.scadding

I can confirm all the things you asked me are correct. I’ve now noticed that my log commands do appear in the log files, even if they didn’t appear in the Shotgun console, so tk-clarisse does get recognized.

I’ve also realized that it is indeed a regex problem with my Clarisse executable path, since the default tk-clarisse COMPONENT_REGEX_LOOKUP doesn’t account for beta versions. Adding the following line to my EXECUTABLE_TEMPLATES solved my issue:

“C:/Program Files/Isotropix/Clarisse iFX {version} {service_pack}b/Clarisse/clarisse.exe”,

Note the “b” after {service_pack}.

It’s working now. Thank you for your help!