Unable to unregister a folder & register a new one

I made the rookie mistake of creating a shot in SG, then running the Create Folder script, then realising I created the wrong shot and renaming it without unregistering the folder first.

Later I tried to create a new shot with the same name I gave the other one originally, but when trying to run Create Folder on this I get:

Folder creation aborted: The path /path/to/shot/seq2/shot2 cannot be processed because it is already associated with Shot shot1 (id 8817) in Shotgun. You are now trying to associate it with Shot shot2 (id 8871). If you want to unregister your previously created folders, you can run the following command: tank unregister_folders /path/to/shot/seq2/shot2

Trying this gives me:

‘/path/to/shot/seq2/shot2’ is not
registered in Shotgun - ignoring.
No associated folders found!

same goes for the original seq1/shot1, and addressing the shot id direclty.

I tried deleting the shots and creating them again, but to no avail.

Is there anything that can be done? I would be ok with completing deleting them in SG and starting fresh, but I don’t know how (they still show up in the trash)

Thanks, Alex

Try a local cache sync first:

tank synchronize_folders

and then a unregister.

See this doc for more:

Ok, thanks. Tried it in the shell in the shotgun project root:
/mnt/software/shotgun/project tank synchronize_folders --full

Command: Synchronize folders

Ensuring that the local folder representation is up to date…

Doing a full sync.

Local folder information has been synchronized.

But then running unregister_folders on both shots still gives me:


‘/path/to/shot/seq2/shot2’ is not

registered in Shotgun - ignoring.

No associated folders found!

Trying to run Create Folders gives me the same “already registered” error message

Maybe try unregistering all paths for the Shotname?

tank Shot shot2 unregister_folders

1 Like

Ok. that did work - I did have to unregister shot2 with its id though, shotname wouldn’t work.

Thank you!

There you go, yeah sometimes things can get a bit messy, I’m not sure why…

As long as you managed :slight_smile: