Tk-multi-workfiles2 failing to initialize

Hi All!

We wanted to update the tk-houdini app to the latest as the version (1.8.1) does not load the SG toolkit menu for Houdini 20+ versions.

When I updated the app and its dependencies, I am facing this error.

Error: SG tk-maya: App /disk/shotgun/install/app_store/tk-multi-workfiles2/v0.15.1 failed to initialize. It will not be loaded: The framework instance tk-framework-qtwidgets_v2.x.x required by tk-multi-workfiles2 v0.15.1 can not be found in environment Environment project.yml.

Any Clues?


Hi @harsh !

This seems to be a problem with the version of the qtwidgets framework, check the info.yml file in the engine (tk-houdini) for the version that is needed (usually this information is at the enf of the file), and check your frameworks.yml file on the env folder in the toolkit configuration to see what version are you currently using.
Info.yml view example:

frameworks.yml view example:

Thanks for you reply @Jaziel

There was indeed this mismatch!

The way I solved this is to copy over the shotgun/install folder from our working show to the new show and update the engine_locations.yml to update the,
type: app_store
name: tk-houdini
version: v1.8.7

to use v1.8.7 for tk-houdini which is compatible with h20+ versions to load toolkit!

It worked fine, but I wish the tank updates ALL tk-houdini did version resolution and resolve better! Its very hard to update the apps as the possibility of new recipe having issues is always a certainty!

1 Like