Tank shell engine commands incorrectly displaying

I have 2 software items defined in the software entity for 3dsmax, “3ds Max” and “3ds Max Pre”. The versions for both are set to 2020. When I run the shell “tank” command, I’m getting 2 entries that are displaying incorrectly for 3dsmax and I cannot run using the commands listed.

tk-multi-launchapp:3ds Max Pre:3ds_max_2020

3ds Max using our pre-release code for testing

tk-multi-launchapp:3ds Max:3ds_max_2020

Launches and initializes an application environment.

How can I fix this to resolve to something tank will recognize?




Hi @mdthielen

Is the real version for the pre release is 2020? You could check Max install folder. It should be different than a released version.



1 Like

Hey @mdthielen

Normally the command would look something like:

./tank 3dsmax_2021

I’m not sure where the : characters or the tk-multi-launchapp bit is coming from. Just to confirm, you’re saying that when you just run ./tank that is what you see as the commands?

That doesn’t look standard, I think we would probably need to see your config to try and understand what is happening here, please could you put in a support ticket and we can feedback here in this thread.

1 Like

Oh also if indeed that command you posted is correct you would probably need to wrap it in quotes since it contains spaces:

./tank "tk-multi-launchapp:3ds Max Pre:3ds_max_2020"
1 Like

To confirm, when I run ./tank in the shell, one of the commands I see to launch with tank is
tk-multi-launchapp:3ds Max Pre:3ds_max_2020
In the software page, if I set the version for the 3ds Max Pre to 2020 and no other 3ds Max entry on the software page has version set to 2020, then the command in the shell shows up “normally” as 3ds_max_2020.


Hey Mark!

I took a look at your site, and did some (admittedly light) testing with my own: I added 2019, 2020 as the value of the version field on my Maya software entity. For me, it worked fine – I just had launchers for maya_2019 and maya_2020 listed when I ran tank.

So… I think what’s actually at play here is that you are using the Group field. My guess is that it’s using that long colon-separated launcher name in order to avoid ambiguity – it’s basically namespacing.

You have 2020 listed for both 3ds Max and 3ds Max Pre, and they are both using the same engine. My hope would be that it generates the string that tank uses from the Software Name field, but maybe it looks like it’s coming from the engine. Even when I change my Software Name from Maya to Georgia (why not :slight_smile: ), the tank command still lists maya_2019 and maya_2020.

So… with that in mind, I guess there’s a feature request in there to respect the Software Name field, but I’d expect the request to be rejected because it will break existing workflows. I can still run this by the team and see if they have any ideas, but I’d love to hear your thoughts first.

1 Like