ShotgunEventDaemon not running in background

Hi, I’ve not been able to run shotgunevents in background (using the start argument).
Or better, it does start but apparently it closes immediately after, because I can’t find the process.
Using foreground it runs without issues. That’s how I’ve been running it while I try to find a solution to this problem.
The logs work when running using foreground. When I run it in background, the logs stay untouched.

I can’t figure out what it could be. Maybe someone else here has faced a similar issue.

Thanks guys

That’s odd. Perhaps it’s the environment is different, or some permission issue.

1 Like

Environment is the same as when I run in foreground. As for permissions, I’m not sure.
I thought that foreground and background are basically the same during execution, thus requiring the same permissions

I thought background runs a service?
So would need different permissions and also could mean the environment changes.

What OS are you running on?
Have you reviewed the wiki?

When run in background it creates a daemon. It shouldn’t be a service afaik.
A service would require managing it through systemd right?

I had gone through the wiki, but re-reading it I noticed they use sudo to launch the daemon. And with sudo it runs fine :tada:. So it is indeed a permission issue, although I can’t figure out what exactly.
Now though I’m not able to stop it. Deleting the file doesn’t seem to stop it.
Using kill [PID] does work, but isn’t what’s suggested in the wiki.

You can set a systemd service to run as a specific user. I guess the daemon should run fine as a normal user - it doesn’t need any special permissions. I think the lower port ranges require root.
What do you do to stop the service, systemctl stop deadline10launcher? Probably again due to permissions.