Shotgun Desktop UI doesn't show on Centos 7.6

Hi everyone, hope someone can help me with this:

I installed SG Desktop from rpm package on Centos 7.6, when I run it, the initial loading dialog shows and initialization seems to go ok, but after “Building UI” the dialog vanishes and Desktop app UI doesn’t show up. Shotgun Create works as expected so Qt based SG UI stuff should work, and I also see tank toolkit action menu populated in SG web database. When I run desktop in terminal it prints out “libpng warning: iCCP: known incorrect sRGB profile” five times and nothing else comes up after that.


Hi Hendrik

Thanks for reporting this, we’ve also heard another similar report. Right now we are not set up to test on Centos 7.6, but I will create a ticket to investigate.
I’m sorry it’s not working.


Also I’m guessing it doesn’t but I thought I’d double check, is the SG Desktop icon appearing in the task tray?

Feeling pretty daft now… I had legacy tray items hidden in theme, when I enabled them I can now access SG desktop from tray.


Ah interesting! Thanks for sharing the tip, and no worries at all thats good info to know.

Hi, I have this problem too in fedora 32 after upgrading to shotgun_desktop 1.6.1.
The version 1.5.9 works with some gnome extension for showing legacy tray icons, but after the update the icon disappears :frowning:

CentOS 7 doesn’t come with the Qt 5 libraries that the new Shotgun Desktop > 1.6 are now using.

Try sudo yum install -y "qt5*". It will install all Qt 5 components, which is a bit bloated, but it will at least get you covered.

Then if that still don’t work, you can try to launch Shotgun Desktop without LD_LIBRARY_PATH set, so in a terminal:

LD_LIBRARY_PATH= Shotgun &   # if "Shotgun" is found in $PATH

It doesn’t help. I’ve most qt libraries already installed…
I still don’t see the tray icon - note that it is executing Python 2. Maybe switching to Python3 can help? But I don’t know if there are any options to set the python version for the desktop app.

EDIT: setting SHOTGUN_PYTHON_VERSION=3 doesn’t help, still no icon.

EDIT2: I’ve reinstalled the 1.5.9 and now I can see the icon.
[offtopic]I’m thinking about leaving the gnome, because I’m really angry about installing extensions for general functions like desktop icons, tray icons, task bar…[/offtopic]

I’ve installed Xfce and I can confirm that the problem with the icon is Gnome related.
v1.6.1 is working in Xfce with no problem…