Shotgun Desktop not opening

Hi all,

I’ve come across a new issue. Shotgun Desktop will not open the app UI at all, it goes through the Starting up Toolkit process but doesn’t open a window.

It’s running in the background but can’t open the app at all. I’ve tried uninstalling, removing all temp/cache files and reinstalling but no luck.


If this is a with in the past week or so that you have installed this the newer version Shotgun desktop was causing some issues in our pipe the Id look into installing 1.5.6 or 1.5.7 instead of 1.6.1

Hi guys,

I had a similar problem. With version 1.6.1, the DCCs don’t open and the Shotgun Desktop just doesn’t log anything, neither in the Shotgun Desktop console nor in the tk-desktop.log. I did this test on Windows 10, so I don’t know if this version is working on Linux or macOS.
For now, we just return to version 1.5.3 and that solved it.


How did you revert the version?

Hi everyone,

We’d like to apologize, but something slipped through the cracks when we validated Shotgun Desktop 1.6.1 with older versions of the tk-desktop engine. We spent of lot of time making sure we reported incompatibilities when trying to load a version of tk-desktop that wasn’t Python 3 compatible in the Python 3 mode, but have been blindsided by Python 2 mode not being backwards compatible with older engines.

The gist of it is that because we are now packaging PySide2 instead of PySide, the PySide2 API doesn’t quite behave the same (QAction’s trigger signals being the biggest offender here) and it has introduced some bugs for users who have locked their site configuration’s tk-desktop engine to v2.4.12 and lower.

To avoid any future confusion with our users, we’ve released yesterday an update for Shotgun Desktop’s startup code that takes into account the tk-desktop version, the Shotgun Desktop version and reports any incompatibilities. It should auto download to your computer next time you launch Shotgun Desktop.

The pop-up will provide an explanation of the issue and suggest two ways to fix the problem.


Hopefully this will clear any confusion around this issue.

1 Like

To add to JF’s point, you can see all the Toolkit component version dependencies for v1.6.1 of Desktop in the Desktop Release Notes.

And @Ricardo_Musch, to answer your question, you can download any old versions of Desktop from the above link if you need to revert.

1 Like

Hi, I downloaded shotgun desktop v1.6.1 and updated my site config by editing the in the engine_locations.yml to version 2.5.12 but the app still doesn’t work and says i need to update the tk-desktop. is there another location where it needs to be updated?

i also tried using shotgun’s master version of the tk-config-default2 which i assume has all the required updates/fields for shotgun desktop v1.6.1 and it’s still not working. I get the pop-up in the screenshot above that says ‘your version of tk-desktop is not compatible with shotgun desktop v1.6.1’

what am i missing?

I’m gonna bump this.

Without updating anything to our site config related to tk-desktop and not updating the installed version of SG Desktop my Shotgun Desktop has stopped showing the GUI. The icon appears in the taskbar or the tray but the GUI is white when I hover over it and will not show.

Tried updating from 1.5.5 to 1.5.9 but to no avail.

Why does this happen?

So I’ve noticed on Windows 10 that if I switch my Main displays (Display Settings → Make this my main Display) SG Desktop re-appears.

Very strange…

We see this semi-frequently, where it starts up, but then you can never see it on screen and in Task View it’s whited out. The only fix we’ve found is to do an entire profile reset, whcih is fairly ridiculous to have to do.

Did my solution above not fix this for you?
It seemed to work every time for me now.

I’m afraid it didn’t, no.

Came to troubleshoot and found this thread.
Some team members are having this same issue. Windows 10 user and a Mac OS user.
Multiple reinstalls have not fixed it and we have tried the display settings trick.

Did anyone have any luck figuring this out?


On Windows, sometimes we had to delete the entire shotgun branch in the Registry (HKEY_CURRENT_USER\SOFTWARE\Shotgun Software\tk-desktop I think, not sure), because there was a corrupted setting for the window. We did not figure out exactly which one it was.

Hi I’m on windows 10 and shotgrid desktop has suddenly stopped working for me as per above- it launches but the window is jumping off screen somewhere. I have tried uninstalling and reinstalling. I can’t revert back to an older version, that won’t install.
I’ve tried all the monitor tricks. This is so frustrating, any ideas? Thanks

1 Like

Did you try the registry suggestion? Even reinstalling does not wipe all stored settings.

The Desktop window is probably offscreen.
End all additional instances of SG Desktop if you have multiple running (via Task Manager). Then shift-right click on the SG icon in taskbar, then choose ”move” and then move the mouse to bring it on screen.