Shotgun Desktop Browser Integration

Cheerio everyone,
I’m having difficulties trying to get the browser integration of Shotgun Desktop up and running. I’m running Firefox v69.0.3 64bit on win7 as recommended in this article.
Shotgun Desktop is running a dev config located on my local disk which is really just a cloned version of tk-config-default2. Shotgun Desktop itself is at v1.5.6.
I have already added the server security exception to allow the local webserver hosted by Shotgun Desktop as described in this article.
Our shotgun site is at v8.7.0.2711 (build 8a68fb5).

Launching Shotgun Desktop tells me the webserver is running

[    INFO] WebSocketServerFactory (TLS) starting on 9000
[    INFO] Starting factory 

…followed by loads of debug records which do not show any errors.

When logging into our shotgun site i get

[ INFO] Connection accepted.

Right-clicking on some project tells me that Shotgun is retrieving actions and gives me the following log output:

[    INFO] Connection accepted.
[   ERROR] Attempted to communicate without completing encryption handshake.
[   ERROR] Attempted to communicate without completing encryption handshake.
[    INFO] Connection closed.
[   DEBUG] Reason received for connection loss: [Failure instance: Traceback (failure with no frames): : Connection to the other side was lost in a non-clean fashion: Connection lost.

Opening a project in shotgun produces the following log output:

[    INFO] Connection accepted.
[   ERROR] Attempted to communicate without completing encryption handshake.
[   ERROR] Attempted to communicate without completing encryption handshake.
[   ERROR] Attempted to communicate without completing encryption handshake.
[   ERROR] Attempted to communicate without completing encryption handshake.
[ WARNING] dropping connection to peer tcp4:127.0.0.1:52451 with abort=True: WebSocket closing handshake timeout (peer did not finish the opening handshake in time)
[    INFO] Connection closed.
[   DEBUG] Reason received for connection loss: [Failure instance: Traceback (failure with no frames): : Connection to the other side was lost in a non-clean fashion: Connection lost.

I have tried with multiple versions of firefox in 32 and 64 bit variants including the latest version but nothing seems to be working.

Could someone please point me in the right direction to fix this issue?

Greets,
Tony

3 Likes

Hey @tonyd I can’t offer any help but can report that I experienced this as early as two days ago in both Chrome and Firefox as well, but it seems to not be an issue today.

Our IT was performing some maintenance on our network at the time, so I’m not sure of what the cause issue actually was. The error points to a localhost IP so the network maintenance may have been coincidence…

1 Like

Hey Tony! We need a bit more information in order to debug this one. Specifically, it’d be useful to have:

  • the name of your shotgun site
  • whether this ever worked in the past or if you’re just trying to get it working for the first time
  • a copy of tk-desktop.log from the appropriate directory for your operating system
  • and a screenshot of the Javascript console in the browser when you see this behavior.

If you’d prefer to send that info along privately, feel free to email support@shotgunsoftware.com and reference this forum post.

thanks!

1 Like

Hey Tannaz,
thanks for your reply!
I’ve actually already opened up a support ticket. I’m sorry but sometimes I find it difficult to determine whether to write to support or to the community ¯_(ツ)_/¯
Nevermind… I will reference this post in my support thread.

1 Like

@tonyd Hi Im having the same error logs , can I know how you solved it? thanks!

1 Like

Hi @macbeth,

Sorry you are seeing the same error here.

Prior to us doing it in a private way, a few thing you could self check here:

  • Could you please confirm that you are using the recommended version of browser listed here and added the server security exception to allow the local webserver hosted by Shotgun Desktop as described in this article.

  • Could you please try to navigate to the following web-page and add an exception ?
    https://shotgunlocalhost.com:9000/

  • Is there any proxy/firewall set on your browser or networking? The shotgunlocalhost.com cert is registered to 127.0.0.1 , which you probably need to exclude in your restriction.

( a bit background: We have flipped a setting under the hood for everyone’s site in the 8.5 release so that users will stop using self-signed certificates for browser integration and will use the shotgunlocalhost.com certificate specified by the site. That’s why you could re-generate the cert on SG desktop now.)

If you have read till here, it means none of above save you, then please write to support@shotgunsoftware.com with ALL the following information:

  • the name of your shotgun site
  • whether this ever worked in the past or if you’re just trying to get it working for the first time
  • a copy of tk-desktop.log from the appropriate directory for your operating system
  • and a screenshot of the Javascript console in the browser when you see this behavior.

We will carry on our investigation there.

4 Likes

Thanks a lot! indeed adding shotgunlocalhost.com to my proxy bypass list, make it work.

3 Likes