Multi-Part EXRs not showing Multi-Layers

Hi All,

i would like confirmation that RV cannot show multi-layer EXRs (shows RGB, but not AOVs rendered in EXR) when said EXR is multi-part, one part per layer.


1 Like

HI @jvpike.

If you check the session manager and open up the source, you’ll see all your channels exposed there.

If you toggle between the standard view and isolating on one AOV, and save a session on each side and diff it, you’ll see that the UI is controlling the RVFileSource.request.imageComponent property, which should also be controllable either via the API or through Image>Remap Source Image Channels, where you can do something like: R,x,z to remap Red to R, Green to x, and Blue to z.

Do be careful, if you are designing a pipeline around multi-layer exrs (rather than Multi-part) as there’s no quick way to read/decode only the channels you want to see with multi-channel. Performance will take a huge hit if you start loading up your AOVs even though you aren’t looking at them, because the channels aren’t easily mapped into isolated blocks of memory on disk (like they are with multi-layer).


If some process you are writing EXRs does not support multi-part EXRs, I highly recommend contacting the developers of said process/application, to support it.

hi @Michael.Kessler

Thanks for replying!

i think there is some miscommunication going on… I have a multi-part EXR with embedded AOVs. When i load this EXR into RV, RV does not show the AOVs. Even though they are definitely there (confirmed in numerous compositing packages).

Is there a setting to have RV display AOVs on Multi-Part EXRs (one part per layer) rendered out of Nuke?

1 Like

Have you looked at the session manager to find your layers? When viewing your exr, press X, then scroll to the top of the window and open the details on your source you are trying to look at.

After drilling down a couple times into that you should be able to see your AOVs. From there you can change to those layers/channels

Do they fail to show up in that view?

Correct- they are not showing up in that view

When I render the same exr as a single-part or multi-part (one part per VIEW), they appear

Hey @Michael.Kessler !

I had @jvpike put in this post. I think it has to do with how the different EXRs we have the header info encoded. I’ll have to talk with JV of how we’re encoding it.

But to fully explain our examples:

Our one-part-per-layer example has 2 parts, each of the 2 “parts” has channels with names (like “R”, “G”, “B”), and a part “name”. That part “name” is not shown by RV, which is the crux of JV’s question.

In a one-part-per-view example, we got those same 6 channels, but all together in one part, and each channel has the full name in it, like “MyAOV.R”, “MyAOV.G”, “MyAOV.B”, and RV parses the “.” and displays “MyAOV” as a grouping.

Would you guys be willing to post an example EXR here (unless you already have a ticket into Autodesk)

I’m wondering if RV can’t do cross-part channels or something like that.