How to modify the version name being created by the Flame on publish

Hello, I am trying to figure out how to take control and modify the name of the publised file that is created from Flame. At the moment I am running a zero config and the version names contain this “%08d.”, I am looking to remove that from the actual version name. Making this “TST100_TEST_480_v001.%08d.dpx” become this “TST100_TEST_480_v001.dpx”.

There are various ways but all of them will require coding:

  • Run a Event Daemon with a script that filters the version name on creation and filters out the %04d
  • Create a webhook that is triggered on version creation to filter the name
  • Create a new distributed config and edit the hooks responsible for creating or extracting version names from the name.

All of these require knowledge of Python and familiarity with the SG api or Toolkit

thanks for the reply. My intent was to find out which hooks are responsible for the creating or extracting the version names from the name.

If using the Publish2 app, then by default the version name is set in this line in the upload_version hook:

1 Like

For Version name you would indeed not want the frame padding in the name but you would want the version number component in there.


For Published File name you would want the version component and the padding stripped.


The Loader can then collate all the published files with that namespace in a list.

I was able to get this worked out, thank you. By any chance do you know how to take control of the version names that come out of Nuke? currently, all the versions that come from Nuke are coming out in lower case, i was hoping to get them to uppercase

i seemed to have spoken too soon. i cant for the life of me figure this out. I modified to remove the pattern from the name but it does not work. any other ideas?

how did you modify this?

Did you create a new distributed config and point the hook from {self} to {config} in the yaml config?

I tried just modifying the py file within the app on my flame (linux) and tested rendering from there. i was able to make adjustments to the path_info file but it seems that when i do an initial publish, a nuke cant find the file as its looking for the padding in the name. support couldnt help either, they just pointed me to this conversation.

Do you have any experience with modifying the SG toolkit?
Simply modifying the file won’t work unless you then reload the project in SG desktop.

Furthermore this change won’t last, you have to create a custom config based on the current “no setup” config and amend the changes there and point the hook to a custom version of the hook.

I would recommend reading up on this process here:

and following the following tutorial: