How do I set No Conversion/No Correction as a preference?

When looking at my files I want to skip the step where RV linearizes files and then outputs them in sRGB display space. How do I override this to have:

RV -> Color -> No Conversion
RV -> View -> No Correction

How do I accomplish this so that the settings is persistent?


Please note that if you’re skipping RV’s linearization pipeline, you’ll need to familiarize yourself with how RV handles color, since skipping linearization step might result in odd colors when layering some filters in Views (stack/view/sequence). You can see more info here:

Now, if you’re still looking to progress in this direction, there are two separate things happening here. RV Color refers to the color profile in the actual image file, while the RV View is the display conversion that RV will use to transform the image to provided display. You will need to handle them separately.

Display settings can be set in RV preferences to be loaded every time you launch RV. These are the View -> Linear to Display Correction settings. You will need to create a display profile and then set it in preferences:

View -> Set to No Correction
Then go:
View -> Create/edit display profiles -> Click + -> Specify a name and any description you may need
RV -> Preferences -> Video tab -> Output Device -> use Module Profile (pick the profile you just created)

Please note that this profile is hardware-specific, which means that the outcome will highly depend on the hardware the RV is launched from and you may need different profiles for different hardware if you’re looking to extend this workflow to the rest of your studio.

If you set “No Correction” in RV Color -> File nonlinear to linear conversion, RV will read the color information directly from the input source. This means that whatever color space you define in your input source, won’t be automatically linearized by RV. You can override RV’s conversion in two potential ways:

– 1. Programmatically override global settings by specifying the source setup in RV. Looks like you’re on the right path with displayGroup1_colorPipeline_0.color.sRGB. However, to completely disable the transform, you will need to zero out gamma and rec709 in that displayGroup as well. Here are the settings and values you’ll need:

displayGroup1_colorPipeline_0.color.sRGB = 0
displayGroup1_colorPipeline_0.color.Rec709ToLinear = 0
displayGroup1_colorPipeline_0.color.fileGamma = 0.0

If you’d like to turn the transform back on, here are the RV defaults:

displayGroup1_colorPipeline_0.color.sRGB = 1
displayGroup1_colorPipeline_0.color.Rec709ToLinear = 1
displayGroup1_colorPipeline_0.color.fileGamma = 1.0

There’s some more information on source setup package here:
Automated Color and Viewing Management Breakdown of sourceSetup in the source setup Package

– 2. Forcing input source color based on file type. You can define it using environment variables. The environment variable that RV looks for is in the format of RV_OVERRIDE_TRANSFER_<type>. So for example, if your colorspace is rec709 for tiff files, you can set RV_OVERRIDE_TRANSFER_TIF=Rec709. You can set the environment variables using a wrapper script before launching RV. This way you can set per-filetype color settings in a very flexible way. For example, you can define different settings per-shot. Some more info here:
Automated Color and Viewing Management The default source group complete behavior

Hope this helps!