FPTR Desktop 1.9.1 and Rocky 9.4

Hi everyone!

I currently try to use FPTR Desktop 1.9.1 on Rocky 9.4 and I have trouble getting the desktop server to work. The application itself runs fine, but I can see in the logs that the desktop server is running into this error:

ModuleNotFoundError: No module named 'OpenSSL' 

This in turn means that I do not get the right click menu in the FPTR browser session.

I have all necessary system libraries installed (as mentioned in this thread) and I searched through the folder structure of FPTR Desktop and cannot find OpenSSL anywhere (which makes sense). So the question is: Is this a known issue? Is there anything I can do to make it work? Or do I need to accept that FPTR Desktop is not ready for Rocky 9 yet?


It appears to be working for me after installing compat-openssl11 after installing that does it still not work for you?

1 Like

Hi @Ahuge !

Thanks for the suggestion! Unfortunately that does not help in my case. I have all the system libraries installed, but it is the “OpenSSL” python module that is missing from the FPTR Desktop installation.
A workaround I found is:

  1. Install python 3.10
  2. Pip install “pyOpenSSL” to it
  3. Copy the “OpenSSL” folder from that installation to the FPTR Desktop python site-packages folder.

This feels incredibly hacky though. I think I need to raise a support ticket.

Thats very interesting @Fabian

In my installation it appears to have OpenSSL.

Are you downloading from the new “Flow” download link?

That is interesting indeed! Will check that out first thing tomorrow morning!

Thanks for letting me know!

I found the issue. It is a mean combination of things we have here. We have taken over the site config which had an old version (v1.5.3) of the tk-framework-desktopserver listed in the frameworks.yml. This version does not include the required python packages for Python 3.10 which PTR Desktop 1.9.1 is using. Updating tk-framework-desktopserver to v1.7.0 has solved the issue.
Thanks again @Ahuge !