Config requires Toolkit Core v0.18.172


I can’t do Advanced Project Setup anymore, as Shotgun Desktop cant seem to se tk-core last version:

The correct version seems to be installed on my workstation:

I can use the command “tank core” on other projects directories to update tk-core on those projects, but it’s impossible to do i before doing an advanced setup.

Trying to update tk-core in projects via cmd ‘tank core’ command will exit with an error:

Screening Room integration right inside your application.

DEBUG [12:03:20 971.999883652]: Exiting with exit code None

Does anyone have an idea how I can pass this problem?


Hi Ben

So the advanced project setup is complaining that the config SG Desktop is running is using an older version of core than the project config you are wanting to setup.
If you check the about box on SG Desktop, it should tell you what version of core it is using:


Since we just pushed out a new version of both the tk-config-basic (which desktop uses and automatically updates on) and tk-config-default2, I suspect that you probably just need to re start SG Desktop to get the latest update and it will start using v0.18.172.

1 Like

SG Desktop is using Core v018.168, indeed.

Restarting it does not seems to trigger the update. i tried to uninstall and reinstall but nothing changed.

Hmm what does the about box state is the Toolkit Basic Configuration version, for you?


Ah OK, thanks, it looks as though you have taken over your site config so you no longer recieve automatic updates. I.e. you have a PipelineConfiguration entity on your Shotgun site that is not assigned to a project.
You will need to update the core on that config, by changing the version number in config/core/core_api.yml, and then restarting Shotgun Desktop.

1 Like

I did not take over the config yet on this project, I just created in the website it using another project as template.
I think the problem is that the project I used as template do not have a Pipeline Configuration at all, as I never did the Advanced Setup for this template project.

So I don’t yet have a config/core/core_api.yml file for this new project.

I tried using another config on the new project with a desciptor in Pipeline Configuration Page on the website, then change the core_api.yml tk-core version in this config, hen gave a tank_name to the project using the website, and now I can open it on SG Desktop…

But tk-core is still on the old 18.168 version:

SGDesktop does not seem to care about the core_api.yml file when using descriptors?

Hey @benwall please could you privately message me you site url, so I can check out your setup.

It doesn’t matter that you haven’t setup your project, since the setup wizard would be unavailable if you had. The issue is that the config you are trying to setup is requiring a newer version of core than SG Desktop is running. Your about box is showing that the reported site config is not an official tk-config-basic config coming from our app store, so it appears like it has been taken over, but I would like to check, before I can be sure.

1 Like

Just to wrap up our private conversation here back in the main thread.
It looks like you had set up a temporary site config, perhaps it was unintentionally set up as a site config, i.e. you just left off the project by mistake. That config was pointing to a gitrepo which contained a config, which probably had its core_api.yml set to use 168.
Once you trashed that config, and restarted Desktop, it reverted to using the automatically updating config, which has a core of 172 and so the setup wizard started working again.

I didn’t change anything, I think it was the deletion of the site config that fixed it.

To break it down a bit here, you had

  • A project that had not been setup before, and you were wanting to run the advanced setup wizard on it.
  • You encountered the error saying the config required core, v018.172, but you were running v0.18.168.
  • What the error meant by "You are running version v0.18.168" was that Shotgun Desktop’s config was running on core v0.18.168.
  • Shotgun Desktop as a whole uses a “site” config, which is a PipelineConfiguration entity with no Project assigned. This config is where it gets the core version it is uses for general SG Desktop operations.
  • As soon as you enter a project in SG Desktop that has been set up with its own config, and launch apps, it will not use the site config/core, and will use the project’s config/core.
  • You had a custom site config. Although I couldn’t see the files, I assume it used the older core v0.18.168.
  • So as soon as you trashed the site PipelineConfiguration entity and restarted desktop, it went back to using the default site config, which is whatever the latest version of tk-config-basic is defined in our app store.

I hope that helps explain, but it sounds like it’s all sorted for you now, sorry for the confusion.


Thanks a lot Philip, it’s really clear! It’s all sorted out :slight_smile:

1 Like